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1. Indtroduction

Welcomel

And thank you for purchasing our AZ-Delivery ESP8266 microcontroller
with integrated 0.91" OLED display.

On the following pages, we will take you through the first programming steps.
We wish you a lot of fun!

This board with an ESP8266 chip and an integrated charging interface,
for one battery pack

can be programmed under NodeMCU and Arduino.

We cover the programming process in Arduino in this eBook.

The board has 32MB flash memory,

WLAN and 12 1/0 pins (i*c, SPl, PWM and Analog Input).

The display is 0,91" and has a resolution of 128 x 32 pixels.
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2. Programming the ESP8266 with OLED

This ESP8622 compared to ESP8266-01, has more flash memory and

more GPIO ports.

2.1 Preparing the software

The Arduino software seen and used in this step has already been

installed. If, however, you do not have it, then please download and install it

on your PC from this web address: https://www.arduino.cc/en/Main/-
Software#. Additionally, the driver for the CP210x should also have been
installed. If not, then you should know that it comes with the Arduino

software.

After all of the basic requirements have been met, we can now start with

the installation of the software. The Arduino software will firstly need all of

the information about the ESP8266, which we can do by entering the fol-

lowing web address, under the ,Preferences” > ,,Additional Board Adminis-

trators-URLs":

http://arduino.esp8266.com/stable/package_esp8266com_index.json

-
Voreinstellungen

Einstellungen | Netzwerk |

Sketchbook-Speicherort:

C:\Users\Florian\Documents\Arduino

Editor-Sprache: Systemstandard -
Editor-TextgréBe: 12

Oberflachen-Zoomstufe: [¥] Automatisch % (erfordert Neustart von Arduino)

Ausfiihrliche Ausgabe wihrend: [~ Kompilierung [~] Hochladen
Compiler-Warnungen: Keine -

[] Zeilennummern anzeigen

|| Code-Faltung aktivieren

|| Code nach dem Hochladen tberpriifen

|| Externen Editor verwenden

|| Aggressively cache compiled core

|¥] Beim Start nach Updates suchen

| 7] Sketche beim Speichern auf die neue Dateierweiterung aktualisieren (.pde -> .ino)

[7] Speichern beim Uberpriifen oder Hochladen

C:\Users\Florian\AppData\Local\Arduino 15\preferences. txt

(erfordert Neustart von Arduino)

Zusatzliche Boardverwalter-URLs: |http://arduino.esp8266.com/stable /package_esp8266com_index.json @

S0

L ——

I Durchsuchen

oKk | [ Abbruch
—_—
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If you have already entered the link, click on the button and add a new line in the window.
Confirm the entry by clicking on ,,OK". Once this is completed, go to , Tools” > ,,Board” »
»Board Administrator” and install the ESP8266 library. Search for ,ESP8266", in the
board administrator, in

the search engine, located in the top right. As aresult, you will get the package from
ESP8266 Community. Select this one and click on install.

-
@ Boardverwalter b

Typ  Alle ~ | ESPB266

esp3266 by ESP3266 Community

In diesem Paket enthaltene Boards:

Generic ESPE266 Module, Olimex MOD-WIFI-ESP8266(-DEV), NodeMCU 0.9 (ESP-12 Module), NodeMCU 1.0 (ESP-12E Maodule),
Adafruit HUZZAH ESP28266 (ESP-12), ESPresso Lite 1.0, ESPresso Lite 2.0, Phoenix 1.0, Phoenix 2.0, SparkFun Thing, SweetPea
ESP-210, WeMos D1, WeMos D1 mini, ESPinc (ESP-12 Module), ESPino (WROOM-02 Module), WifInfo, ESPDuino, 4D Systems
gen4 IoD Range, DigiStump Oak.

Cnline help
Maore info

240 - | Installieren

After a successful installation, next to the package INSTALLED will be now shown.

esp8266 by ESP8266 Community Version 2.4.0 INSTALLED

In diesem Paket enthaltene Boards:

Generic ESP2266 Module, Olimex MOD-WIFI-ESPE266(-DEV), NodeMCU 0.9 (ESP-12 Module), NodeMCU 1.0 (ESP-12E Module),
Adafruit HUZZAH ESPE266 (ESP-12), ESPresso Lite 1.0, ESPresso Lite 2.0, Phoenix 1.0, Phoenix 2.0, SparkFun Thing, SweetPea
ESP-210, WeMos D1, WeMos D1 mini, ESPino (ESP-12 Module), ESPino (WROOM-02 Module), Wiflnfo, ESPDuino, 4D Systems
gen4 IoD Range, DigiStump Oak.

Cnline help

Mare info

The next step is to select the correct board:
Under Tools > Board: ,,Generic ESP8266 Module”
Port: “COMxx" (here is your port of the serial adapter)
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[Werkzeuge| Hilfe

Automatische Formatierung Strg+T

Sketch archivieren

Kodierung korrigieren 8 neu laden

Serieller Monitor Strg+ Umschalt+M
Serieller Plotter Strg+Umschalt+L

WiFil01 Firmware Updater

Board: "NodeMCU 1.0 (ESP-12E Module)" ) _ A
Flash Size: "4M (LM SPIFFS)" j | HSEIe Foo W

Debug port: "Disabled” ! ESP8266 Modules

Debug Level: "Keine" ) Generic ESPE266 Module

IwIP Variant: "v2 Prebuilt (MS5=536)" ) Generic ESP3285 Module
CPU Frequency: "80 MHz" ! ESPDuino (ESP-13 Module)

Upload Speed: "115200" | Adafruit HUZZAH ESP8266
Port: "COM13" ' ESPresso Lite 1.0
Boardinformationen holen ESPresso Lite 2.0

Phoenix 1.0
Programmer: "AVR ISP" [ Phoerix 218
ool NodeMCU 0.9 (ESP-12 Module)

@ NodeMCU 1.0 (E5P-12E Module) k

The COMPort can be accessed via the device manager and can also be changed:

Datei Aktion Ansicht 7
e | D E HE & B &S

4 = Florian

b3 Akkus
4 .."? Anschliisse (COM & LPT)
? Silicon Labs CP210x USB to UART Bridge (COM12) |
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2.2 The Arduino Code

Now that the wiring has been completed, we can start writing our first code.
We let all Wi-Fi networks in our surroundings to be shown.
To do this, select under File » Examples > ESP8266Wifi > WifiScan.

Datei| Bearbeiten Sketch Werkzeuge Hilfe

Neu Strg+N

Offnen... Strg+0

Letzte 6ffnen

Sketchbook dl

Beispiele 'l A

SchiieBen Strg+ W Beispiele fir NodeMCU 1.0 (ESP-12E Module)

Speichern Strg+5 ikl ’

Speichern unter... Strg+Umschalt+5 e ’
EEPROM L4

Seite einrichten  Strg+Umschalt+P ESPA266 »

Drucken Strg+P ESPE266AVRISP ’
ESPB266HTTP Client L4

Voreinstellungen  Strg+Komma
ESPE266httpUpdate r

Beenden Strg+Q ESP8266HTTPUpdateServer 4

: ] ESP8266LLMNR ;

ESP8266mDNS »
ESP8266MetBIOS »
ESP826655DP *
ESP8266WebServer L
ESPB266WiFi ' HTTPSRequest
ESP8266WiFiMesh 'i HTTPSRequestCACert
Ethernet(esp8266) ' NTPClient
Hash * WiFificcessPoint
SD(esp8266) ' WiFiClient
Servo(esp8266) ' WiFiClientBasic
SoftwareSerial + WikEieris
Tl j WiFiMutti
TFT_Touch_Shield_V2 | WiFiScan
Ticker ! WiFiTelnetToSerial
Beispiele aus eigenen Bibliotheken WiFiWebServer

ESP8266 Mikrocontroller
mit integrierten 0.91 OLED Display

Page 7.



Fk_ Delive ry ESP8266 Mikrocontroller

Ihr Experte fur Mikroelektronik! mit integrierten 0‘91 OLED Displqy

After the code has been displayed, we click on and verify our program:

If everything is correct and our program contains no errors,

Das Maximum si|

40%) des dynamisc

Once the 100% has been reached, then the program has been completely transferred.
Open the Serial Monitor in the Arduino software:
Tools > Serial Monito

Werkzzuge) Hie

Automatische Formatierung Strg+T

Sketch archivieren

Kodierung korrigieren & neu laden

Serieller Monitor D? Strg+Urnschalt+M
Serieller Plotter Strg+Umschalt+L

A new scan is automatically started

every 5 seconds and the result is

distributed via the serial interface.
3can start

At the beginning of each and every scan  |scan done
14 networks found
WLAN-419458 (-78)*
FRITZ!Box Fon WLAN 7170 (-81)+%
Fritz-DVBC (-75)*
FRITZ!Box Fon WLAN 7170 (-82)*
Netgear WGR-814 (-60)*
Telekom FON (-78)
devolo-f£4068dbb4335 (-93)*
Netgear WGR-814 (-83)*
FRITZ!Box 7362 SL (-83)%*
: KazbelBox-36C4 (-79)*
. . .. . : Vodafone Hotspot (-80)
be listed. It will look similar to the image : Nodebonie: Homerpit 173

on the right. 13: o2-WLANOS (-91)*
14: Netgear WGR-B814 (-47)*

scan start

is displayed, and it ends with

scan done.

Wooh =] & A = L R

=
=]

Finally, all available Wi-Fi networks will

=
=

iy
%]
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In order to be able to control the display, we would need the corresponding libraries (infor-

mation) in the Arduino software.
Begin under Sketch » Include Library > Manage Libraries ...

m__Werlczet_J_g_e Hilfe

Uberpriifen/Kompilieren Strg+R
Hochladen Strg+U
Hochladen mit Programmer Strg+Umschalt+U

Kormpilierte Bindrdatei exportieren Strg+Alt+5

Sketch-Ordner anzeigen Strg+K

A

Bibliothek einbinden ) A
' Biblictheken verwalten... h

Datei hinzufdgen...

The library administrator and search there for ,,u8g2"

r — B
9 Bibliotheksverwalter Lﬁ
Typ _Alle ~  Thema alle ~  |uBg2

LCDMenulib2 by Nils Feldkaemper

Easy creation of a tree based menu with screensaver and multi layers. Examples for the basic function and different ocutput
types [serial monitor, liquidcrystal, i2c, graphic displays (u8glib / u8gzlib... )]

More info

U8g2 by oliver

Monochrome LCD, OLED and elnk Library. Display controller: 55013205, S5D1206, 5501209, S5D1322, S5D13225, 5501327,
55D1229, SSD1606, SSD1607, SH1106, T6062, RAS835, LC7981, PCD8544, PCF2812, UC1601, UC1604, UC1608, UC1610, UC1611,
UC1701, ST7565, ST7567, ST7588, ST75256, NT7524, IST2020, ST7920, LD7022, KS0108, SED1520, SBN1661, IL2820, MAX7219.
Interfaces: I12C, SPI, Parallel. Monochrome LCD, OLED and elnk Library. Successor of U8glib. Supported display controller:
5501305, 5501306, S501309, 5501322, S5D1325, S5D1327, 5501329, 55D1606, 5501607, SH1106, T6963, RABB35, LC7981,
PCDE8544, PCFB812, UC1601, UC1604, UC1608, UC1610, UC1611, UC1701, 5T7565, ST7567, 5T7588, 5T75256, NT7534,
IST3020, ST7920, LD7032, KS0108, SED1520, SBN1661, IL3820, MAX7213. Supported interfaces: 12C, SPI, Parallel. Features:
UTF8, =700 fonts, U8xE char output.

More info

Version 2.20... Installieren

|
L

-

Schliefen

After the package has been selected, click on install, located on the bottom right.
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After waiting for a few seconds, the ,INSTALLED" will appear.

U8g2 by oliver Version 2.20.12 INSTALLED

Monochrome LCD, OLED and eInk Library. Display controller: SSD1305, S5D1306, 5501309, S5D1322, SSD1325, S5D1327,
55D13229, SSD1606, SSD1607, SH1106, T6963, RAS835, LC7981, PCD8544, PCF8812, UC1601, UC1604, UC1608, UC1610, UC1611,
UC1701, ST7565, ST7567, ST7588, ST75256, NT7534, IST3020, ST7920, LD7032, KS0108, SED1520, SBEN1661, IL3820, MAX7219.
Interfaces: 12C, SPI, Parallel. Monochrome LCD, OLED and elnk Library. Successor of U8glib. Supported display controller:
SSD1305, 55D1306, S5D1309, SSD1322, 55D1325, 5501327, SSD1329, 55D1606, 5501607, SH1106, T6963, RAB835, LC7981,
PCD8544, PCFB812, UC1601, UC1604, UC1608, UC1610, UC1611, UC1701, ST7565, ST7567, ST7588, ST75256, NT7534,
IST3020, ST7920, LD7032, KSO0108, SED1520, SBN1661, IL3820, MAX7219. Supported interfaces: 12C, SPI, Parallel. Features:
UTF8, >700 fonts, USx8 char output.

More info

Now you can close the window, and commence with the programming process.
Select under Examples > U8g2 » full_buffer >» GraphicsTest:

Bearbeiten Sketch Werkzeuge Hilfe

MNeu Strg+MN

Offnen... Strg+0

Letzte 6ffnen

Sketchbook |

Beispiele l‘ &

SchlieBen Strg+W Beispiele aus eigenen Bibliotheken |

Speichens g Usg2 | full buffer 1 FPS
Speichem unter... StrgeUmschalt=S |y ompaTiREL | e— il < | Gapticatest
Seite einrichten  Strg+Umschalt+P v page_buffer ) HelloWorld

Now a longer code will be opened. In the first lines, a lot of display types are registered.
These, however, have the “//" characters at the beginning of the line. For our display, we
now have to search for and activate this line, by removing the “//" characters, placed at the
beginning of the line:

U8G2_SSD1306_128X32_UNIVISION_F_HW_I2C u8g2(U8G2_RO, /* reset=*/
U8BX8_PIN_NONE); // Adafruit ESP8266/32u4/ARM Boards + FeatherWing OLED

After the transmission L] the display will now show demo texts and images.

ESP8266 Mikrocontroller Page 10.
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Based on this demonstration, we can also program a scrolling text.

For a smooth playback, we should change the CPU frequency to 160MHz and the SPI
memory to 3MB (3M SPIFFS).

Board: "ModeMCU 1.0 (ESP-12E Module)”
Flash Size: "4M (3M SPIFFS)"

Debug port: "Disabled”

Debug Level: "Keine"

IwIP Variant: "v2 Prebuilt (M55=536)"
CPU Frequency: "160 MHz"

Upload Speed: "115200"

Port: "COMI13"

Note: if you would like to make alonger scrolling text, then you have to activate the 16-bit
supportin the u8gz.h file. The file can be found in the Arduino directory:

Arduino\libraries\arduino_168079\src\clib\u8g2.h
Inline 72 thereis  //#define UBG2_16BIT
It should be changedto  #define U8BG2_16BIT

Subsequently, save the file and then re-transmit the code.

ESP8266 Mikrocontroller Page 1l.
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The code is as follows:

finclude <UBgZ2lib.h>
UBGZ 8SD1306_ 128X3Z2 UNIVISICON F HW I2C u8g2(U8BGZ RO, /* r
UBX8 PIN NONE);
uBg2 uint t offset;
uB8g2 uint_ t width;
char *text =
1 setup(void) {
uBg2.begin();
uBg2.setFont {uBg2 font logisoso3Z tf);
width = uBg2.
uBg2.setFontMode (0) ;

i
(1]
i
ot

I

"Florian

",
r

}

void loop (void) {
u8g2_ uint_t x;
uBg2.firstPage () ;
do {
x = offset;
uBg2.setFont (uBg2 font logisosc3Z tf);
o {
uBg2 .drawlUTFB (x, 32, text);
x += width;
} while ( x < uBg2.getDisplayWidth() );
u8g2.-etFonttn?gi_fon:_;:giscs:?f_tf);
ug2. tCursor (0, 64); .
uBg2.print (width) ;
} while ( uBg2.nextPags() );
offset —= 1;
if ( (uBg2 uint t)offset < (uBg2_uint_t) - width ){
offset = 0;
delay (1000} ;
uBlg2.clearBuffer();
}
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