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STOP

Atlas Scientific does not make consumer electronics.

This equipment is intended for electrical engineers. If you are not familiar
with electrical engineering or embedded systems programing, this product
may not be for you.

This device was developed and tested using a Windows computer. It was not
tested on Mac, Atlas Scientific does not know if these instructions are
compatible with a Mac system.
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Operating principle

The Wi-Fi hydroponics kit has been designed to provide the engineer with a simple way
of remotely monitoring and controlling a hydroponics system's chemistry. Sensor data
is uploaded to ThingSpeak ™, a free, cloud-based data acquisition and visualization
platform. The Wi-Fi hydroponics kit has also been designed to be easily modified by the
engineer. Feel free to change the sensors or functionality of the device to meet your
specific needs.

Overview
CPU

The Wi-Fi hydroponics kit is controlled using an Adafruit Feather HUZZAH as its CPU. The
HUZZAH is programmed using the Arduino IDE and uses an onboard ESP8266 as its
Wi-Fi transmitter. Adafruit Feather HUZZAH datasheet.
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Sensor ports

The Wi-Fi hydroponics kit PCB has 5 sensor ports. Three of the ports are electrically
isolated. The isolated ports are marked pH, Conductivity, and AUX. The isolated ports
are needed to take noise-free electrochemical readings. Because the sensing element of
a temperature sensor is never in direct contact with the water, electrical isolation is not
needed for temperature sensing.

The AUX port can be used to add an additional sensor of your choice. The terminal block
marked Port 5 has been designed to connect one or more dosing pumps to the device.
However, the port could also be used to connect a gas sensor.
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https://learn.adafruit.com/adafruit-feather-huzzah-esp8266

PCB

The overall design of the PCB is quite simple. The CPU is powered and programmed
through the panel-mount USB connector. The CPUs onboard voltage regulator supplies the
board's power bus with 3.3V at 500 mA peak. All connected sensors are running at 3.3V.
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Each of the four main sensor ports have an enable pin, which must be set correctly to
power the sensor. The enable pins are found here:

The first three pins (pH, Cond and Aux) must be set low to power on the sensor.
The last pin (Temp) must be set high to power on the sensor.

Truth table

Sensor Power

Sensor port 5 (the terminal block) does not have an enable pin and can not be turned off.

. AtlasScientific
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Data protocol

The CPU communicates with all peripheral sensors using the 12C data protocol. All data
lines are directly connected to the CPUs I2C port. Using a different data protocol with this
circuit board is not possible.

It is important to keep in mind that all Atlas Scientific components default to UART mode.

When adding a new Atlas Scientific component to the kit, it must first be put into 12C
mode. Refer to the component's datasheet for instructions on how to switch it over.

Adding more of the same
sensor or component type

Adding additional components of the same type, such as an additional pH or conductivity
sensor, is not hard to do. As mentioned above, you must set the device to 12C mode, and
you must make sure that its I2C address is not the same as the already existing component.

AtlasScientifico
Hydroponics Kit E _—

mgymmm |
= m mm
pH VCC PRB PGND
EZO™

pH Conductivity Temperature

12C Address 12C Address 12C Address 12C Address
99 (0x63) 100 (0x64) V" 102 (0x66) % 99 (0x63)

Conflicting 12C Address
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This table lists the default 12C address of components commonly added to this kit.

12C Address

I12C Address

EZO EC 100 (0x64)
EZO RTD 102 (0x66)
EZO PMP 103 (0x67)

EZO pH 99 (0x63)

EZO ORP 98 (0x62)
EZO DO 97 (0x61)

Dosing pump

An optional external dosing pump can be added to the Wi-Fi hydroponics kit.
Using the EZO-Expansion Pump Kit is the simplest way to add on a dosing pump.
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A stand-alone EZO-PMP can be used instead of the expansion pump kit; however, you
must manually put the pump in 12C mode and remove the data cable connector.
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https://atlas-scientific.com/peristaltic/ezo-pmp-advanced/

Uploading sensor data
to the cloud

The Atlas-Scientific Wi-Fi hydroponics kit has been designed to upload sensor data to
ThingSpeak™, a free, cloud-based data acquisition and visualization platform. You will be
required to set up a free account with ThingSpeak™ to upload and visualize the data. With
a free account, you can upload data once every 15 seconds. A paid account lets you
upload data once per-second; look here for more info about various ThingSpeak™
services.

Atlas Scientific has no business relationship with ThingSpeak™; we just like how it works.
If you want to use a different service, modify the device as you see fit.

Setting up your Wi-Fi kit
Ste p 1 Setup a ThingSpeak Account

Because the sensor data is stored / viewed on ThingSpeak, you will need
to setup a ThingSpeak account. Create your ThingSpeak account by clicking HERE.

D ThingSpeak" Channels Apps  Support~ Commercial Use  How to Buy

To use ThingSpeak, you must sign in with your existing MathWorks account or create a new one.

Non-commercial users may use ThingSpeak for free. Free accounts offer limits on certain functionality. Commercial users are eligible for a time-limited free evaluation. To
get full access to the MATLAB analysis features on ThingSeak, log in to ThingSpeak using the email address associated with your university or organization.

To send data faster to ThingSpeak or to send more data from more devices, consider the paid license options for commercial, academic, home and student usage.

Email

4\ MathWorks- % )

DATA AGGREGATION

—
‘ | o AND ANALYTICS
No EfU:(.Junl.‘? Create one! . . -_I Q Thingspeak
By signing in you agree to our privacy policy. f,.‘-‘;‘ NIATL!\B
v —
e 2 B
Next =l & Y
- T ¢ > /_". il I
—
i_’ SMART CONNECTED DEVICES g ;l.
2_' ALGORITHM DEVELOPMENT
SENSOR ANALYTICS
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https://thingspeak.com/prices/thingspeak_standard
https://thingspeak.com/login

Ste p 2 Create a Channel

Your data is uploaded to ThingSpeak through a ‘Channel.” Select New Channel

|:| ThingSpeak“‘ Channels - Apps ~ Support~ Commercial Use How to Buy

My Channels Help
. S ¢ mriki Bariar Collect data in a ThingSpeak channel from a device,
e Search by tag EI from another channel, or from the web.

Click New Channel to create a new ThingSpeak
channel.

Click on the column headers of the table to sort by the
entries in that column or click on a tag to show
channels with that tag.

|:| ThingSpeak“ Channels~ | Apps~  Support~ Commercial Use ~ How to Buy

New Channel Help

Channels store all the data that a ThingSpeak application collects. Each channel includes

Name Atlas Sensors
eight fields that can hold any type of data, plus three fields for location data and one for
status data. Once you collect data in a channel, you can use ThingSpeak apps to analyze and
Description visualize it.
Channel Settings
Field 1 pH * Percentage complete: Calculated based on data entered into the various fields of a
channel. Enter the name, description, location, URL, video, and tags to complete your
channel.
Field 2 EC (uS/cm)
* Channel Name: Enter a unigque name for the ThingSpeak channel.
Field 3 Temp (°C) » Description: Enter a description of the ThingSpeak channel.

Fill out the highlighted boxes. (Be sure to click on the checkboxes to enable field 2 and 3)
For reference, this is what we entered.

Name Atlas Sensors
Field1 pH

Field 2 EC (uS/cm)
Field 3 Temp (°C)

Scroll to the bottom of the page and click Save Channel.

- AtlasScientific
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Ste p 3 Get ThingSpeak API keys

After you saved your channel settings, you will be redirected to your channel page.
Click on API keys.

|:| ThingSpeak“‘ Channels ~ Apps ~ Support~ Commercial Use How to Buy

My Channels Help
. S N Collect data in a ThingSpeak channel from a device,
S EI from another channel, or from the web.

Click New Channel to create a new ThingSpeak
Name Created Updated channel.
Click on the column headers of the table to sort by the

entries in that column or click on a tag to show
channels with that tag.

& Atlas Sensors 2020-02-14 2020-05-1123:04

l Private ‘ Public ‘ Settings | Sharing ‘ APl Keys ‘ Data Import / Export

Learn to create channels, explore and transform
data.

Learn more about ThingSpeak Channels.

I:l ThingSpeak“ Channels ~ = Apps~  Support~ CommercialUse  How to Buy

Atlas Sensors

Channel 1D: XXXXXX
Author:
Access: Private

Private View Public View Channel Settings Sharing APl Keys Data Import / Export

Write API Key Help

AP keys enable you to write data to a channel or read data from a private channel. APl
keys are auto-generated when you create a new channel.

Key 00 0.0.0.0.6.4.0.4.9.6.44
APl Keys Settings
* Write API Key: Use this key to write data to a channel. If you feel your key has

been compromised, click Generate New Write API Key.
o Read API Keys: Use this key to allow other people to view your private channel

Be sure to save your Channel ID and Write API Key we are going to need these, in the
next few steps.

- AtlasScientific
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Ste p 4 Make sure your Arduino IDE libraries are up to date

A Make sure you have the correct path for the Esp8266 Library

In the IDE, go to File > Preferences
Locate the Additional Boards Manager URLS text box.

Preferences pod
Settings  Network

Sketchbook location:

C:\Users\Moah\Documents \Arduingo Browse
Editor language: System Default ~ | (reguires restart of Arduino)

Editor font size: 12

Interface scale: Automatic | 100 5 % (requires restart of Arduina)

Theme: Default theme -+ | (requires restart of Arduino)

Show verbose output during: [ ] compilation [ ] upload

Compiler warnings: Mone

[] Display line numbers [] Enable Code Folding

Verify code after upload Use external editor

Chedk for updates on startup Save when verifying or uploading

[] Use accessibility features

Additional Boards Manager URLs: | http:/farduino.esp&266.com/stable fpackage_esp&266com_index.json ﬁ

More preferences can be edited directly in the file

C:\Users\Moah\AppDataLocal\Arduino 15'\preferences. bt

F=did mmlo wkesrm Ard e e e e
(edit only when Arduino is not running)

Make sure this URL is in the textbox

http://arduino.esp8266.com/stable/package_esp8266com_index.json
Click OK.

- AtlasScientific
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B Update the esp8266 board

In the IDE, go to Tools > Board > Boards Manager

File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch
hydropunlcs:k Fix Enceding & Reload
Manage Libraries... Ctrl+Shift+1
som reRding ool Monitor CtrlsShiftep |- 100 READ_RESEONSE 13
/fastep 1 tell
Serial Plotter Ctrl+ Shift+L

f/atep 2 cons
/istep 4 tell
//atep 3 cons

enum reading_|

bool polling
bool send to_|

int return_co
uint32_t next
const unsigne
unsigned int

const unsigne|

const unsigne
const unsigne|

void setup()

pinMode (EN_|

WiFi101 / WiFiNINA Firrnware Updater

Board:

Upload Speed: "115200"

CPU Frequency: "80 MHz"

Flash Size: "4MB (F5:2MB OTA:~1019KB)"
Debug port: "Disabled”

Debug Level: "None"

IwlP Variant: "v2 Lower Memory"

VTables: "Flash"

Exceptions: "Legacy (new can return nullptr)”
Erase Flash: "Only Sketch"

S5L Support: "All 551 ciphers (most compatible)”
Part

Get Board Info

Programmer: "AVRISP mkll”

Burn Bootloader

g we just received

Boards Manager...

iy

Arduino AVR Boards
Arduine Yin

Arduine Uno

Arduine Duemilanove or Diecimila
Arduine Mano

Arduine Mega or Mega 2560
Arduine Mega ADK
Arduine Leonardo

Arduine Leonarde ETH
Arduine Micro

Arduine Esplora

Arduine Mini

Arduine Ethernet

pinMode (EN_

7 UUITUIT;

&9 Boards Manager X
e g
Type Al w | | esp8266
espB266 ~
by ESP8266 Community version 2.6.3 INSTALLED
Boards included in this package:
Generic ESP8266 Module, Generic ESPB285 Module, ESPDuino (ESP-13 Module), Adafruit Feather HUZZAH ESP8266, Invent One,
XinaBox CWO01, ESPresso Lite 1.0, ESPresso Lite 2.0, Phoenix 1.0, Phoenix 2.0, NodaMCU 0.9 (ESP-12 Module), NodeMCU 1.0
(ESP-12E Madule), Olimex MOD-WIFI-ESP8266(-DEV), SparkFun ESPB266 Thing, SparkFun ESP8266 Thing Dev, SparkFun Blynk
Board, SweetPea ESP-210, LOLIN{WEMOS) D1 R2 E mini, LOLIN{(WEMOS) D1 mini Pro, LOLIN{WEMOS) D1 mini Lite, WeMos D1
R1i, ESPino (ESP-12 Module), ThaiEasyElec's ESPino, Wiflnfo, Arduino, 4D Systems gend IoD Range. Digistump Oak, WiFiduino,
Amperka WiFi Slot, Seeed Wic Link, ESPactro Core, Schirmilabs Eduino WiFi, ITEAD Sonoff, DOIT ESP-Mx DevKit (ESP8283).
Cnline Help
More Info
Select version - Install Update Remove
L
Close

In the search bar of the Boards Manager, lookup esp8266.
Update to the most recent version if you don't already have it.

(Version 2.6.3 in not the most recent version)

- AtlasScientific
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C Download the ThingSpeak library for Arduino

Click HERE to download the latest version of the ThingSpeak library.
Don’t unzip it!

Import the .ZIP file into your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

File Edit Sketch Tools Help

Verify/Compile Ctrl+R
Upload Ctrl+L
hydrop Upload Using Programmer  Ctrl+Shift+U

Export compiled Binary Ctrl+Alt+5
£NUN e D COMPENSATE, REQUEST DEVICES, BRELD RESPONSE }:
ffatep Show Sketch Folder Ctrl+K ng
i) Include Library | A
:::::EZi Add File... Manage Libraries... Ctrl+5Shift+|

Add ZIP Library...

D Add the EZO 12C Library

To download the Ezo_I2c¢ library file, click HERE.

¥ master ~ F 1branch D 0tags Go to file

2] Clone @

HTTPS  GitHub CLI

@ Atlas-5Scientific removed redundant examples, aquaponics kit has pump code by ¢

Examples removed redundant examples, aquapon NEED= " aa iRl COMAE TS = c e Ata T3y |
O Ezo_i2ccpp added the get_address() method to the  Use Git or checkout with SVM using the web URL.
D Ezo_i2ch added the get_address() method to the

¥ Open with GitHub Desktop

[M Ezo_i2c_util.cpp Created libraries for common functions
M Ezo_i2c_utilh Created libraries for common functions  [§) Download ZIP
[ LICENSE Initial commit 2 years ago
™ READMEmd Update README.md 18 days ago

Don’t unzip it!
Import the .ZIP file to your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

- AtlasScientific
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https://www.arduinolibraries.info/libraries/thing-speak
https://github.com/Atlas-Scientific/Ezo_I2c_lib

Ste p 5 Flash the Hydroponics meter with the correct code

A Select, open and adjust the code you want to use for your Wi-Fi Kit

File> Examples> EZO_I2C_lib-master> Examples> IOT _kits>

You have two choices of code:
Legacy Hydroponics_kit or Legacy Hydroponics_kit_with_DO

(The “with DO" version is for people who want to add Dissolved oxygen)

File Edit Sketch Tools Help
MNew Ctrl+M
Open... Ctrl+0
Open Recent
Sketchbook
Examples 3
Close Ctrl+W
Save Ctrl+5
Save As... Ctrl+Shift+5
Page Setup  Ctrl+Shift+P
Print Ctrl+P
Preferences  Ctrl+Comma
Quit Ctrl+Qy

11
12 WiFiClient clien
13
6 1 B ot bt sk o

15 |const
1€ |const
17 |const
18 |const

15 //-==-

(58]

58]
S0

Ezo_bo

Ezo_bo

s8]
58]

Ezo_bo

ST N |
o)

Ezo_bo

58]
wn

Ezo_bo
EH,
EC,
RTD,
EME

ST oS ]
1 o™

[V R S T %
H o Ww W
—
~e

fad
[5%]

Ezo_bo

(ST V5 )
e

L
L

//gets

const

(%3]
(]

String ssi
String pas
long myCha
char * myW

ard PH = E
ard EC = E
ard RTD =
ard PMP =

ard device|

ard* defau

the lengt

uint8 t de

A&
ESP32 BLE Arduino

ESPmDNS

FFat

HTTPClient
HTTPUpdate
HTTPUpdateServer
NetBIOS
Preferences
5D(esp32)
SD_MMC
SimpleBLE

SPI

SPIFFS

Ticker

Update
WebServer

WiFi
WiFiClientSecure
WiFiProv

Examples from Custom Libraries
ACROBOTIC S5D1306

Adafruit BME280 Library
Adafruit BMEGE0 Library

Adafruit ESPE266

Adafruit HTU21DF Library
Adafruit SHT31 Library
Adafruit Si7021 Library

atlas_gravity
EspSoftwareSerial
Ezo_|2c_lib-master
Ezo_uart_lib-master
FID
StepperDriver
ThingSpeak
INCOMPATIBLE

v

Bc library

[ library from https://g

Lfi hydroponics kit that uses the Adafruit huzzah32 as its computer.

/finclude wifi library

//include thingspeak library
//imports a 4 function segquencer
//imports a 1 function sequencer
//brings in common print statements

ithub.com/Atlas-Scientific/Fro I2c lib

/

b ingSpeak Credentials——-——

/declare that this device connects to a Wi-Fi network,

//The name of the Wi-Fi network you are connecting to
//Your WiFi network password

//Your Thingspeak channel number

//¥our ThingSpeak Write API Eey

//create a PH circuit object, who's address is 9% and name is "PH"
//create an EC circuit object who's address is 100 and name is "EC"
//create an RTD circuilt object who's address is 102 and name is "RTD"

/fcreate an PMP circuit object who's address is 103 and name is "PMP"

//fan array of boards used for sending commands to all or specific boards

Examples *

Lly so we

vice list)

13 Copyright © Atlas Scientific LLC

12c_lib_examples
10T _kits
Projects

Sequencer_lib_sxamples

>lr|=- talking to

agquaponics_kit

hydroponics_kit
legacy_hydroponics_kit
legacy_hydroponics_kit_with_DO

add new boards

poel_kit

thingspeak_example

- AtlasScientific
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B Fill in your Wi-Fi / ThingSpeak credentials

Fill in your Wi-Fi name and Password, along with the Channel ID and Write API Key to the
code. (see step 3)

@ hydroponics_kit | Arduine 1.8.13
File Edit Sketch Tools Help

hydroponics_kit

#include

1 <iot cmd.h>

2 #include <ESPB266WiFi.h> //include esp8266 wifi library

3 #include "ThingSpeak.h" //include thingspeak library

4 #include <sedquencerd.h> //imports a 4 function sequencer

5 #include <sequencerl.h> //imports a 1 function sequencer

6 #include <Ezo_iZ2c_util.h> //brings in common print statements
7 #include <Ezo_iZc.h> //include the EZO I2C library from https://github.com/Atlas-Scientific/Fzo I2c
8 #include <Wire._h> //include arduinos iZ2c library

9

10 WiFiclient client; //declare that this device connects
11

iz Fill in your Wi-Fi / ThingSpeak Credentials———————

13 const String ssid = "Wifi Name": //The name of the Wi-Fi network you
14 const String pass = "Wifi Password"; //¥our WiFi network password

15 const long myChannelNumber = 1234566; //Your Thingspeak channel number

16 const char * myWriteAPIRey = "X3OOOODUOOOOONINH"; //¥our ThingSpeak Write API Key
vy —_—— e ——

C Setting up your pump

If you do not have a pump attached, you can just skip this part. The code is rather
self explanatory. You set what parameters will trigger the pump to engage.

48 //parameters for setting the pump output

49 $define PUMP_BOARD EMP //the pump that will do the output (if theres more than one)

50 #define PUMP_DOSE -0.5 //the dose that the pump will dispense

51 #define EZO_BOARD EC //the circuit that will be the target of comparison

52 #define IS GREATER THAN true //true means the circuit's reading has to be greater than the comparison value,
53 #define COMPARISON VALUE 1000 //the threshold above or below which the pump is activated

- AtlasScientific
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Ste p 6 Setting up the HUZZAH board

A Set the target CPU to flash

Tools> Board> Adafruit Feather HUZZAH ESP8266

'?_?,' hydroponics_kit | Arduino 1.8.12

File Edit Sketch Tools Help

Aute Format Ctrl+T
Archive Sketch
hydrnpnnlcszk Fix Encoding & Reload
Manage Libraries.., Ctrl+Shift+|
S T i ety Cirl+Shift+M |- -+ BEAD_RESPONSE }:
J/latep 1 tell
Serial Plotter Ctrl+Shift+L

ffatep 2 cons
flatep 4 tell
//atep 3 cons

enum reading |

bool polling
bool send_to |

int return_co
uint32 t next
Cconst unsigne
unsigned int

Cconst unsigne

const unsigne
Cconst unsigne

WIF101 / WiRiMIMNA Firmware Updater

Board:

Upload Speed: "115200"

CPU Frequency: "20 MHz"

Flash Size: "4MEB (F5:2MEB OTA:~1019KE)"
Debug port: "Disabled”

Debug Level: "Mone"

hwiP WVariant: "v2 Lower Memory"

WTables: "Flash"

Excepticns: "Legacy (new can return nullptr)”
Erase Flash: "Only Sketch"

S5L Support: "ANl 551 ciphers (most compatible)”
Port

g we just recelwved

Boards Manager...

&

Arduine Yin

Arduino Uno

Arduinc Duemilanove or Diecimila
Arduinc Mano

Arduinc Mega or Mega 2560
Arduinc Mega ADE

Arduine Leonardo

Arduine Leonarde ETH

Arduine Micro

Arduinc Esplora

Arduine Mini
Get Board Info T
void setup() Arduinc Ethernet
Programmer: "AVRISP mkll" Arduine Fio
pinkode (EN_ Burn Bootloader Arduino BT

]_:-il:l:‘f:ﬂ.i {EH_ Ty UOILOI] s
pinMode (EN_AUX, COUTFUT);
digitalWrice (EN_PH, LOW):

15 Copyright © Atlas Scientific LLC

Adafruit Feather HUZZAH ESP8266
LilyPad Arduino
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B Adjust CPU Settings

Make sure the CPU settings on the Adafruit Feather HUZZAH ESP8266 are correct.

To adjust the CPU settings, click Tools.

For reference, this is what Atlas Scientific set the CPU settings to.
(your options may not be exactly the same, just try and match them as closely as possible.)

hydroponics_kit | Arduine 1.8.12

File Edit Sketch Tools Help

hydroponics_lK

//enable pins
const int EN |
const int EN |
const int EN |

Ezo_board* de

/fgets the le
CoOnst uintd_t

enum reading |
Flfatep 1 tell
[/atep 2 cons
Sfatep 4 tell
//fatep 3 cons

enum reading |

bool polling
bool send to |

int return_ co
uint3i2_t next

conat unsigne
unsigned int

Auto Format

Archive Sketch

Fix Encoding & Relead
Manage Libraries...
Serial Monitor

Serial Plotter
WIFI101 / WiFiNINA Firmware Updater

Board: "Adafruit Feather HUZZAH E5PE266"
Upload Speed: "115200"

CPU Frequency: "80 MHz"

Flash Size: "4MB (F5:2MB OTA:~1019KB)"
Debug port: "Disabled”

Debug Level: "Mone"

lwlIP Variant: "vZ Lower Memory"

WTables: "Flash"

Exceptions: "Legacy (new can return nullptr)”
Erase Flash: "Only Sketch"

551 Support: "All 55L ciphers (most compatible)”
Port

et Board Info

Programmer: "AVEISP mkll"

Burn Bootloader

Ctrl+T

Ctrl+Shift+|
Ctrl+Shift+ M
Ctrl+Shift+L

16 Copyright © Atlas Scientific LLC
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Ste p 7 See the readings

Open your Arduino serial monitor.

(You must have the serial monitor set to the com port from the Adafruit Feather HUZZAH)

@ - o X
Send
Autoscroll [ Show timestamp Carriage return 9600 baud w Clear output

Set to carriage return and 9600 baud.

The Wi-Fi Hydroponics Meter will always attempt to connect to ThingSpeak on bootup.

® - o X
Send

RTD: 23.02 PH: 4.30 EC: 422.15

sent to thingspeak

RTID: 23.03 PH: 4.27 EC: 424.05

sent to thingspeak

RTD: 23.03 PH: 4.27 EC: 424.23

sent to thingspeak

RTID: 23.02 PH: 4.25 EC: 424.2%

sent to thingspeak

RTD: 23.02 PH: 4.25 EC: 424.30

sent to thingspeak

RTID: 23.02 PH: 4.25 EC: 424.30

sent to thingspeak

Autoscroll [ ] Show timestamp Carriage return | | 9600 baud w Clear output

17 Copyright © Atlas Scientific LLC
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If it cannot connect to your Wi-Fi you will see this:

S

Send

connecting to wifi

connecting to wifi

connecting to wifi

RID: 23.02 PH: 4.30 EC:
RTID: 23.02 PH: 4.30 EC:
RTD: 23.02 PH: 4.30 EC:

RTID: 23.02 PH: 4.30 EC:
RTD: 23.02 PH: 4.30 EC:
RTID: 23.02 PH: 4.30 EC:

RTID: 23.02 PH: 4.30 EC:
RID: 23.02 PH: 4.30 EC:
RID: 23.02 PH: 4.30 EC:

RTD: 23.02 PH: 4.30 EC:

RETD: 23.02 FPH: 4.30 EC:
BTO- 23 02 PH- 4 30 FC-

422.15
422.15
422.15

422.15
422.15
422.15

422.15
422.15
422.15

422.15

422.15
427 195

Autoscroll [ ] Show timestamp

Carriage return

2500 baud

L

Clear output

Entering the poll command will stop the Wi-Fi Hydroponics Meter from uploading the
readings to thingspeak, while you debug your Wifi problems.

18 Copyright © Atlas Scientific LLC
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Step 8 Sensor Calibration

Atlas Scientific created a list of calibration commands that are built into the library.
Type in help to see a list of commands.

@E - | P
Send

> help

Atlas Scientific I2C hydroponics kit

Commands:

datalog Takes readings of all sensocrs every 15 sec send to thingspeak

Entering any commands stops datalog mode.

poll Takes readings continucusly of all sensors

ph:cal, mid, 7 calibrate to pH 7

ph:cal, low, 4 calikbrate to pH 4

ph:cal,high, 10 calikbrate to pH 10

ph:cal, clear clear calibration

ec:cal,dry calibrate a dry EC probe

ec:k, [n] used to switch E values, standard probes values are 0.1, 1, and 10

ec:cal,clear clear calibration

For K1 probes, these are the recommended calibration values:

ec:cal, low, 12880 calibrate EC probe to 12, 880us
ec:cal, high, 80000 calibrate EC probe to 80, 000us
rtd:ical, t calibrate the temp probe to any temp value

t= the temperature you have chosen

rtd:cal,clear clear calibration

Autoscroll [] Show timestamp Carriage return -~ | 9600 baud e Clear output

A The poll command

Send the command poll; This will let you see the readings once per second and it will stop
uploading to ThingSpeak while you calibrate.
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B Calibrate pH

When calibrating pH, you must always calibrate to pH 7 first.

Remove the soaker bottle and rinse off the pH probe. Remove the top of the pH
7.00 calibration solution pouch. Place the pH probe inside the pouch and let the probe sit
in the calibration solution until the readings stabilize. This will take about 1 — 2 mins.

1-2 mins

6.917 |

7.126 — X Unstabilized
7.223 X

7.225 |

722> & stabilized

7.225 | Once the readings have stabilized,
ph:cal,mid,7 issue the Mid point calibration
o command. ph:cal,mid,7

Rinse off the probe and repeat this process for both pH 4.00 and pH 10.00.

C Calibrate Conductivity

When calibrating Conductivity, you must always calibrate a dry probe first.

Make sure that the probe is dry before issuing this command, ec:cal,dry
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Once the dry calibration has been completed, place the probe into a small cup of the
12,880pS calibration solution. Shake the probe to make sure you do not have trapped
air bubbles in the sensing area. You should see readings that are off by 1 — 40% from
the stated value of the calibration solution. Wait for readings to stabilize.

12,880pS 12,880pS

Trapped air in sensing check probe connection,
area (shake to remove) +/- 40% you cannot calibrate to 0.

— O X
16,247
15491 [~ X Unstabilized
14,053
13,756

13,756 -
13,756 —Q/Stablllzed

13,756 Once the readings stabilize, issue the low point
ec:cal,low, 12880 calibration command. ec:cal,low,12880
o (Readings will NOT change)

Rinse off the probe before calibrating to the high point. Pour a small amount of the 80,000uS
calibration solution into a cup. Shake the probe to remove trapped air. Again, the readings
may be off by 1 — 40% Wait for readings to stabilize.

— O X
51,674 |
53,826 — X Unstabilized
55,193
56,493 |

56,493 | .
56,493 ~/Stablllzed

56,493 Once the readings stabilize, issue the high point
ec:cal,high,80000 calibration command. ec:cal,high,80000
- (Readings will change, calibration complete).
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D Calibrate Temperature

Calibrating the PT-1000 temperature probe is not required. However, if you want to,
a simple method to calibrate the probe is to place the PT-1000 into boiling water. Then
issue command rtd:cal,t

100 °C

Elevation in meters

305
229
152
76

0
-76
-152

Calibration Complete

22 Copyright © Atlas Scientific LLC Atl aSSCnv!rgml?ntEI!;E!tg



Step 9 imostdone

Once you are finished with calibration, issue the datalog command to resume taking a

reading every 15 seconds and uploading it to thingspeak.

To see the data on your phone, download the ThingSpeak app.

4 May g
34.0
0019 gep on 19 Sep 1237

2:47

Setup Complete!
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