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About Paraben’s iRecovery Stick 
 
Welcome to Paraben’s iRecovery Stick!  
 
This tool allows you to recover data Apple iOS devices such as iPhone/iPad/iPod Touch 
devices. Recovers user data on the device. The iRecovery Stick will work either directly 
with the device via a cable connection through a computer or the processing of an 
iTunes backup file from the computer associated with the device. 
 
All iPhone OS are supported including 1.x-14.x. 
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What’s New? 
• iOS 14 Support: Added support for iOS 14.  
• Improved Recovery: Recoveries from phones encrypted by an iTunes backup 

file with a password will display third party apps data, Health app data, Wi-Fi 
passwords, Web Form passwords, Map history, Siri voice commands, and more. 

Recovering Data from iPhone Devices 
The method to recover data from iPhones and iPads has changed. To recover the most 
data, you must create an iTunes backup file with a password. Once created, the 
iRecovery Stick uses this password to access even more information than it can from 
phones without an iTunes backup password. Also, doing a recovery directly from the 
phone or by using the iTunes backup files recovers the same data. The only exception is 
the direct recovery method will download all MP3 files.  

 
It is strongly recommended that you follow the instructions below to create an iTunes 
backup file with a password. Once created, you can start a recovery directly from the 
phone or from the newly created backup file. 
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Getting Started 
System Requirements 

 
The following requirements must be met to use iRecovery Stick: 

• iRecovery Stick requires a Windows Vista or newer 32 or 64-bit operating system. 
• To use the Export to Microsoft Excel feature, Microsoft Excel must be installed on 

your computer and you must add the .Net Framework programming tools during 
the installation process.  

How to Use iRecovery Stick 
Before you begin, it is highly recommended that you create an iTunes backup with a 
password of your device.  
 
There are two types of iTunes backup files: Encrypted and not encrypted. If you add a 
password to your iTunes backup, it will not only encrypt the backup, but it will also 
encrypt the data on your iOS device. When we use this password during a recovery, we 
gain access to more data than we can with not encrypted backups/phones. 

 
To recover the most data from your iOS device, you must create an encrypted 
backup. Please follow these steps: 
 
 
1. Download and install iTunes from the Apple website: 
https://support.apple.com/downloads/itunes 
 
 
2. Plug your phone into your computer and then click on the device icon: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

https://support.apple.com/downloads/itunes
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3. Click the “This Computer” radial button and then check the “Encrypt local 
backup”. Create your password when asked and then click the “Back Up Now” 
button.  
 

 
Note: Be sure to remember your password. You will need it during the recovery and to 
un-encrypt the phone when your recovery is complete. 
 
 
To start using the iRecovery Stick, do the following: 
 

1. Disable anti-virus software on computer. Occasionally the anti-virus software on a 
computer can interfere with the recovery that is done by the iRecovery Stick. It is 
recommended that you disable this software. 

2. Plug the iRecovery Stick into the USB port of your computer. 
3. Open the USB drive when you are prompted by Windows. 
4. Double-click the iRecoveryStick.exe file. 
5. If drivers for iPhone/iPad/iPod Touch are not installed, the iRecoveryStick.exe file 

will initialize their installation. Follow the installation wizard if needed. 
6. When installation is finished, remove the iRecovery Stick from USB port and restart 

the computer. This will ensure all drivers are installed properly and are ready for 
your recovery.  

7. Ensure the anti-virus software is still disabled when the computer reboots so that 
it will not interfere with the recovery. 

8. If you have created an iTunes backup with a password, you can skip this step. 
Otherwise, turn off the passcode, Touch ID, and Face ID (Settings/Face ID & 
Passcode/Turn Passcode Off and turn off Face ID for iPhone Unlock) 

9. Plug the iRecovery Stick into the USB port of your computer. 
10. Double-click the iRecoveryStick.exe file. 
11. The iRecovery application main window will open. 
12.  You now can start a recovery or load a backup file for recovery using your 

iRecovery Stick. 
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Application User Interface 
Understanding User Interface 

 
The iRecovery Stick interface includes the following parts: 

o The Main page: This page contains information about iRecovery Stick and three 
buttons that let you open the existing workspace, start recovery process from the 
iPhone/iPad/iPod Touch device or iTunes backup files.  

o The Data page: On this page, the recovered data and other backup data received 
from the device is displayed.  

o The Main menu: The menu provides access to the main functionality of Paraben's 
iRecovery Stick. 

 

Main Page 
 
The Main page of iRecovery Stick opens at the program start-up. 
 
It contains the following elements: 

o A tool bar. 
o Short description of iRecovery Stick. 
o Three icons: Start Recovery, Open Workspace, and Start Import from iTunes 

Backup.  
o A link to the Data page if there is any data in the workspace. 

 
From the Main page, you can do the following: 

o Start recovery process from the iPhone/iPad/iPod Touch device or iTunes backup 
files. 

o Define program options. 
o Open an existing workspace.  
o Move to the Data page. 
o Rename the currently opened workspace. 
o Export workspace data to Excel. 

 

Data Page 
 
The Data page opens when data recovery process finishes. This screen will also open 
when you open a workspace or you click the Back to Data link on the Main page.  
 
The Data page contains the following elements: 

o A list of data categories. 
o The Data pane in which data is displayed.  
o The name of the device from which data was recovered. 
o A Search field. 
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o The Details pane, including the Properties tab, the Bookmarks tab, the Search 
Results tab, the Extended View tab, and the Acquisition Details tab.  

o A link to the Main page. 
 
From the Data page, you can do the following: 

o View the recovered data. 
o View the properties of the device from which you recovered data. 
o Search text data in the workspace. 
o Create and access bookmarks. 
o Define program options. 
o Open an existing workspace. 
o Go to the Main page. 
o Save the open workspace using a different name. 
o Export workspace data to Excel.  
o Export location history. 
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Main Menu 
 

File Menu 
The File Menu contains basic file options for working with iRecovery Stick.  

Menu Item Description 
Open Workspace Opens a saved workspace. 
Save As Saves the open workspace under a different name. 
Start Recovery Closes the open workspace and displays a screen from 

which you can select a device to scan.   
Start Import Starts the import of iPhone backup files. 
Export to Microsoft Excel Exports workspace content as an MS Excel (.xls) file.  
Exit Shuts the iRecovery Stick down.  

 
 

View Menu 
The View menu lets you display tools in the iRecovery Stick user interface. 

Menu Item Description 
Properties Opens the Properties pane containing properties of the 

acquired device.  
Bookmarks Opens the Bookmarks pane containing created bookmarks. 
Acquisition Details Opens the Acquisition Details pane containing information on 

device acquisition.  
Extended View Opens the Extended View pane for viewing advanced 

information on recovered data and some application data (e-
mails, etc.) 

Search Results Opens the Search results pane containing results of the 
recent search.    

 
Tools Menu  

The Tools menu lets you check for iRecovery Stick updates and define logging and 
folder options. 

Menu Item Description 
Options Allows you to define logging options and the default folder for saved 

workspaces. 
Validate 
Workspace 

Runs a hash encryption algorithm on a workspace data to ensure 
the data has not been altered if the data is being used as evidence. 

Check for 
Updates 

Connects to the Paraben’s site to download updates.   

 
 

Help Menu 
The Help menu gives access to this help file, information about the iRecovery Stick 
application, and displays registration data. 
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Menu Item Description 
Help Opens iRecovery Stick user documentation. 
About Qt Provides data about the Qt tool, licensed for use in iRecovery Stick. 
About Displays the iRecovery Stick description and the version number. 

Recovering Data 
About Data Recovery 

iRecovery Stick allows you to recover data either from an iPhone/iPad/iPod Touch device 
or from an iTunes backup.  
 
CAUTION: iRecovery Stick places recovered data in a temporary workspace that is automatically 
created in the workspace folder. The folder location is defined in the Options menu and has a 
Workspace<number>.ds name. When you close the workspace, you must save it or you will lose 
the data.  
 

Recovering Data from iPhone/iPad/iPod Touch Device 
The iRecovery Stick acquires data and recovers the data from iPhone/iPad/iPod Touch 
devices. This section explains how to recover data from your iPhone/iPad/iPod Touch. 
 
Before the recovery process starts, do the following:  

1. Turn on the device. 
2. Ensure that the device battery is completely charged. 
3. Ensure that the proper drivers are installed on your computer. Their installation is 

performed automatically at the first iRecovery Stick connection.  
4. Connect the device to the computer with a data cable.  
5. If you have created an iTunes backup with a password, you can skip this step. 

Otherwise, turn off the passcode (Settings/Touch ID & Passcode/Turn Passcode 
Off). 

6. If the device has never been backed up using iTunes and a password, it is highly 
recommended that you create a password protected backup. Please follow the 
instructions at the beginning of this help file to create a password protected iTunes 
backup. If you choose not to do this step, you will not recover as much data as 
possible from the device. 

 
NOTE: If you have iOS 7–11 and newer versions, when you connect iPhone/iPad/iPod Touch device to a 
new computer, you will be asked to confirm that you trust the connected computer. To start recovering 
data, tap Trust in the appeared message on the connected device.  
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To recover data from the iPhone/iPad/iPod Touch: 
 

1. Do one of the following: 
• Click Start Recovery on the Main page.  
• Click File > Start Recovery. 
• Press F5. 

2. Click the image of the device you want to scan. If multiple devices are connected 
to your computer, multiple images are displayed.  
NOTE: If your device does not appear in the list in several seconds after the connection, try to 
disconnect it and then connect back again. If you continue having problems, check your cable 
and make sure it is functioning properly. 

 

 
 
3. Select one of the following acquisition options and click the corresponding button 

to start acquisition: 
• Acquire textual and multimedia data: This type of acquisition allows 

acquiring graphics and multimedia along with the textual data.  
• Acquire all data including 3rd party Apps: This type of acquisition takes 

longer. Acquired data will contain not only text data and multimedia, but a 
full list of applications installed on the device, the list of their permissions, 
and data from most popular applications (Skype, Facebook, etc.).   
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4. The acquisition and recovery process starts. 
5. The details of the acquisition process are displayed in the Data Acquisition pane 

in the bottom of the screen. 
 

 
If an iTunes backup with password has been created, you will be asked to enter that 
password here: 
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Recovering Data from iTunes Backup Files 
 
The iRecovery Stick imports data from the iPhone backup files created by iTunes and 
recovers deleted data stored in them. Starting with iOS 14, we recommend processing 
iTunes backup files that have been encrypted with a password because the iRecovery 
Stick can access more data from encrypted backups. If you do not have an encrypted 
backup, you can create one using iTunes. Be sure to back up using a password. You 
will be asked to enter that password when you start your recovery from the iTunes 
backup.  
 
To generate the backup file in iTunes 
 

• Plug your device into your computer and open iTunes. Click on the device icon:

 
• Select “This Computer”, “Encrypt local backup”, add your password and click 

“Back Up Now”: 

 
 
The default location for iTunes backup files is the as follows: 
 

• Windows XP: C:\Documents and Settings\USERNAME\Application Data\Apple 
Computer\MobileSync\Backup\<sequence of numbers and letters>\Manifest.plist 

• Windows Vista/7/8/8.1/10: C:\Users\USERNAME\AppData\Roaming\Apple 
Computer\MobileSync\Backup\<sequence of numbers and letters>\Manifest.plist 

 
To import the iTunes backup file into iRecovery Stick: 

1. Do one of the following: 
• Click File > Start Import. 
• On the Main page, click the Start Import from iTunes Backup icon. 

2. Navigate to the Manifest.plist file, and then click Open.  
3. If the backup is encrypted, remove the password and make a new backup. Note: 

Encrypted backups cannot be read without the password. 
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Working with Workspaces 
About Workspaces 

 
A workspace is a file with a .ds extension that contains information recovered from a 
single iPhone device.  

Creating New Workspace 
 
When you start data recovery, iRecovery Stick creates a new temporary workspace. The 
workspace is named Workspace<number>.ds. By default, the workspace is saved in the 
current Windows user folder. The workspace is also updated after you create a bookmark. 
You can change the default location where a workspace is saved, and you can use the 
Save As function to relocate and rename a saved workspace. 
 
To create a workspace: 

1. Start the data recovery process. See Recovering Data from iPhone. 
2. Click File > Save As, then click Save.  

To define the default workspace folder: 
1. Click Tools > Options, then type a new name and browse to the folder you want 

to use. 
2. Click Save. 

To change the name of a workspace: 
1. Open the workspace that you want to change. 
2. Click File > Save As. 
3. Browse to the location where you want to save the workspace, and then type a 

new name. 

Opening Existing Workspace 
 
Workspaces created by iRecovery Stick (*.ds files) can be opened from the user interface. 

1. To open an existing workspace, do one of the following: 
o On the Main page, click the Open Workspace button. 
o In the File menu, select the Open Workspace item.  
o Press Ctrl+O. 

 
When you open a new workspace, the currently open workspace closes. Unsaved 
information is lost. 
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Validating Workspace 
 
Through data validation you can check if the workspace data has been altered. This is 
valuable if the data you have collected will be used in court as evidence. 
 
To validate a workspace: 

1. Open an existing workspace with acquired data. 
2. In the main menu, select Tools > Validate Workspace or press CTRL+L. 
3. The data validation process starts. 
4. When the validation process finishes, you will see the message with validation 

results. 

Closing Workspace 
 
The workspace closes when any other workspace opens or iRecovery Stick shuts 
down. 
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Viewing iPhone Data 
 
User data recovered depends on the type of recovery (direct from device or encrypted 
iTunes backup) as well as the apps installed on the device.  
 

o Device properties: The properties of the iPhone from which data was recovered 
are displayed in the Properties tab of the Details pane. Click View Details to open 
the details pane. 

o Data categories: To the left of the Data page, the categories of the backup data 
are displayed. Click the category name to view its content. 

o Backup data: Acquired backup data is displayed in the right part of the Data page. 
Data representation depends on its format. 

 

 
 

Text data includes the following categories: 
o Contacts: The device phonebook. 
o Messages: The device SMS messages. 
o Call History: The device call logs. 
o Organizer: The device calendar, memos, and so on. 
o Internet Data: Includes Safari suspend state, Safari Bookmarks, Safari History, 

Cookies, Delivery Accounts, Mail Accounts, and YouTube bookmarks. 
o Other Data: This data includes device data. To get the most “Other Data”, process 

encrypted iTunes backup files. 
o Applications: This displays a list of all applications installed on the device 

including details for supported apps. 
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Data from each category is displayed in a grid to the right of the Data page. There can be 
several tabs in the grid if data contains sub-categories, such as Calendar and Notes for 
the Organizer.  
 
Multimedia data includes Graphics and Multimedia category. 
 
This data is displayed as thumbnails. You can click a file to view it in a larger view. The 
image opens in the same pane. If necessary (for larger images), it scales to fit the window 
size. To return to thumbnails, click the scaled image.  
 
You can also use external viewers to view multimedia data. To open the image in the 
external viewer, right-click the image and select Open with. 
 

 
 

 
Application data includes a full list of installed applications, parsed application data for 
the most popular applications, and the permission list, which includes the full list of 
permissions an application has and the application suspicion rate basing on its 
permissions. Data is displayed in three tabs: the first tab displays application 
permissions, the second tab includes the list of all installed applications, and the third 
tab displays the parsed application data in the tree-view structure.     
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Searching Data 
 
The iRecovery Stick allows you to search for text data in a workspace. 
 
To search text data: 

1. On the Data page, in the Search Text field (in the upper right corner of the page); 
type the search text you would like to find. 

2. Click Search or press Enter. 
3. The search progress is displayed in the Search Results tab of the Details pane. 

Click Abort to stop the search. 
4. When the search finishes, the search results are displayed in the Search Results 

tab of the Details pane. Each result is displayed as <Category name>\<Sub-
category (tab) name>. 

5. Double-click the search result to navigate to it. 
 

  
When searching, you can use the Search Word List option that allows you to load the 
search expression for a Boolean text search from a file. To create a search words list, 
create the text file (*.txt). Use the new line for OR logic. Words in one line are 
interpreted with AND logic. 
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To use the Load Words option: 
1. On the Data page, in the Search field, click the arrow sign and select Search 

Word List. 
2. In the opened window, click Browse and navigate to the text file with search 

expressions. 
3. Click Start Search. 
4. Data will be found according to the defined search expression. 

 
For example:  
 
Expression in the table Found result Not found 
White cat 
Black 
Dog 

White cat and dog 
Black dog 
White cat and black dog 

White snow 
Gray cat 

White Cat with dog 
Black 

White cat with dog 
Black cat 

Gray cat with dog 
White cat 
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Exporting Data 
Exporting Data to MS Excel 

 
You can export data from the workspace as a Microsoft Excel workbook (.xls file). You 
must have Microsoft Excel installed to be able to use this feature.  
 
To export data: 

1. Click File > Export to Microsoft Excel. 
2. Click Browse to navigate to the destination folder and name the exported file. 
3. Check Open file after generation to open the exported file. 
4. Click Export. 
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Bookmarks 
 
A Bookmark is a pointer to particular areas of interest in the workspace.  
 
Bookmarks include the following information:  

o Item (the name of the first cell of the row to which the bookmark is pointing)  
o Name (the name of the bookmark)  
o Details (the description of the bookmark)  

 

Accessing Bookmarks 
Bookmarks are displayed in the Bookmarks tab of the Details pane. 
 
To view bookmarks:  

1. Do one of the following: 
o Click View > Bookmarks. 
o On the Data page, click View Details (in the bottom left corner).   

2. To view the data, to which bookmark is pointing, double-click the bookmark. 
 

Adding Bookmarks 
To add a bookmark: 

1. Select data to be bookmarked (it can be either a cell of the grid or a row). 
2. Right-click the item and select Add to Bookmarks. 
3. Type a name and a description for the bookmark, and then click Save. 

 

Editing Bookmarks 
To edit a bookmark: 

1. Open the Bookmarks tab of the Details pane. 
2. Right-click the bookmark and click Edit, or, from the menu, click Manage > Edit. 
3. Edit the bookmark name and description, and then click Save. 

 

Deleting Bookmarks 
To delete a bookmark: 

1. Open the Bookmarks tab of the Details pane. 
2. Highlight the bookmark to delete. 
3. Right-click the bookmark and select Delete, or, from the menu, click Manage > 

Delete. 
4. Select Delete All to delete all bookmarks. 
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Troubleshooting Guide 
 
Most issues you will run into are due to phone security or phone encryption (iTunes 
backup passwords). If your phone has a PIN, thumb print, or face ID set you must 
remove them. If your phone is encrypted (i.e. you set a password on the iTunes backup 
file), your only recovery option is to recover from iTunes Backups and you must enter 
the password during the recovery process. To remove the encryption, create an iTunes 
backup without a password. If the phone is encrypted, iTunes will require the iTunes 
backup password to create the new backup. 
 
Another common issue is not having enough space on your computer for the case file 
(recovered data). Case files can be as large as the storage space on your iOS device. 
For example, a 128GB phone may require more than 128GB of free space on your 
drive. If you do not have enough room, you can save the case to a removeable hard 
drive or USB drive. To change the default location where case files are saved, click on 
Tools/Options and then click the “Browse” button to navigate to the drive or folder you 
want to save your case file to. 

Creating Log Files 
 
iRecovery Stick has three options for logging support built right in: 
 

• The Plug-in Log option creates a text file log of the recovery based on the plug-in 
activity. 

• The Serial Log option logs all traffic across the communication port. 
• The GUI Log option logs all events that happened in the iRecovery Stick interface 

during one program session. 
 
Logs contain useful information for resolving issues and adding support for new models.  
The GUI Log is created automatically and rewritten each time when iRecovery Stick is 
restarted. The Plug-in Log and the Serial Log are optional. The best practice is to leave 
these logging options turned off unless you encounter a problem. Then enable both 
logging options and duplicate the problem. These logs may be needed if you call tech 
support to assist you.  
 
To enable the Plug-in Log and the Serial Log creating: 

1. Click Tools > Options. 
2. Check Serial Logs, Plugin Logs, or both. 
3. Click Save. 

 
NOTE: All logs are created in the user folder (by default, C:\Documents and Settings\{user name}\logs 
in Windows XP and C:\Users\Default\AppData\Local\Temp\logs in Windows 7). The Plug-in Log and the 
Serial Log are overwritten when a new recovery process is performed using the same plug-in. 
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iRecovery Stick Options 
 
To define iRecovery Stick options, select Tools-Options.  
 
iRecovery Stick options are the following: 

o Logs:  You can define what logs will be created during the recovery process. The 
Plug-in logs option creates a text file log of the recovery process based on the 
plug-in activity and the Serial logs option logs all traffic across the communication 
port. If you have any problems with iRecovery Stick, send the logs to Paraben. 
The logs destination path is displayed below the logs checkboxes in the Options 
window. 

 
o Default Workspace Folder: When recovery process starts, a new workspace is 

automatically created in the default workspace folder. When you close such a 
workspace, you are proposed to save it under other name. If you do not want to 
save the workspace, click No and the workspace will be deleted. Make sure that 
there is enough space on the disk, on which the default workspace folder is stored. 

 

 
 
 
 
 
 



 

 26 

Additional Information  
 
Paraben Consumer Software offers a variety of tools for investigations. These tools 
include Phone Recovery Stick for Android devices, Data Recovery Stick for deleted data 
recovery of a computer, Chat Stick for review and recovery of instant messaging data, 
and the Porn Detection Stick for the recovery and detection of illicit materials.  
 
For any details on any of these products, please visit us at www.paraben-
consumer.com  
 

http://www.paraben-consumer.com/
http://www.paraben-consumer.com/
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