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WHAT IS WEARTEC?

The Nebraska 4-H Wearable Technology (WearTec) is a National Science Foundation (NSF) funded 
project focused on activities related to wearable technologies. The goals of the project are to 
develop an intervention that focuses on solving real world problems and practicing the engineering 
design process while immersed in the innovative area of wearable technologies.
 
This curriculum was developed for youth in grades 4 to 6 to teach engineering design, computer 
programming, basic circuitry and sewing. The curriculum has been designed to encourage 
connections between in-school and out-of-school time instruction.  Wearable technologies provide 
a powerful, personally expressive tool for use in both formal and informal learning environments. 

These technologies bring together engineering and computing to make computers, which 
are “soft, colorful, approachable, and beautiful”. Wearables offer a window into the world of 
technology enabling students to develop technology literacy in a more inclusive manner than 
game development or educational robotics. The electrical components of wearable technologies 
expose the connections and circuitry that is normally hidden from students. Students can literally 
see the connections between the electrical and technical components when creating circuits with 
conductive thread or copper tape. This provides a tangible artifact that brings relevant theories 
from physics, engineering, and computing to life. Crafting and aesthetics are key components of 
designing wearable technologies further increasing the attractiveness and accessibility to students. 

Creating wearable technologies provides an outlet for personal expression as the end product can 
be worn. This has particular power in attracting female students who tend to be more interested 
in aesthetics, textile design and social connections than their male counterparts.

This material is based upon work supported by the National Science Foundation under Grant 
No. ITEST #1433822 awarded to the University of Nebraska-Lincoln.  Any opinions, findings, and 
conclusions or recommendations expressed in this material are those of the author(s) and do not 
necessarily reflect the views of the National Science Foundation.
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Engineering Design Process (EDP) Overview
The engineering design process is a series of steps that engineers follow to come up with a solution to a 
problem. Many times the solution involves designing a product that meets certain criteria and/or accom-
plishes a certain task.  This process is different from the steps of the scientific method. While scientists study 
how nature works, engineers create new things, such as products, websites, environments, and experiences. 
Because engineers and scientists have different objectives, they follow different processes in their work. 
Scientists perform experiments using the scientific method; whereas, engineers follow the creativity-based 
engineering design process.

It’s important to note that the EDP is flexible. There are as many variations of the model as there are engi-
neers. With WearTec, students work through all six steps, but in real life, engineers often work on just one or 
two steps, then pass their work to another team.

Note that the EDP is non-linear.  At any point, you may return to a previous step to redesign or improve your 
idea.  The EDP is reliant on the iterative process.  An iterative process is a process for reaching a desired 
result by means of a repeated cycle of operations (steps).  The cycle should come closer to the desired result 
as the number of iterations increase.  For example, after you improve your design once, you may want to 
begin all over again to refine your technology. You can use the EDP again and again!

In the WearTec curriculum you will notice symbols to represent each step in the EDP.  These symbols are 
intended to help you identify each steps of the EDP and bring about the thinking associated with that step.  
The symbols can be used for short-hand inclusion in the engineering journal.  A one-page printable format 
of the EDP is found at Appendix A.

ENGINEERING DESIGN PROCESS
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EDP Journal Explanation and Use Guidelines 
An engineering design process (EDP) journal is a working document. It is where ideas, sketches, and stu-
dent reflections are recorded. It is a journal the students will use to document their learning and discovery 
through drawings, data, and record keeping. The journals should show thought behind strategy, designs, 
innovations, and organization. The journals are evidence of how students have grown and overcome 
obstacles in their designs.  Each step of the engineering design process should have a corresponding jour-
nal entry.

Professional engineers use design notebooks to record their thoughts and learn from their experiences.  By 
using a design journal, students are engaging with real-life tools and experiences important for skill and 
interest development.

Key elements 
to incorporate 
in Engineering 
Journal
■■ Use dates
■■ Indicate step of engineer-

ing design process
■■ Write notes on inclusion or 

exclusion of ideas
■■ List pros and cons of solu-

tions
■■ Describe reasoning for 

iterations
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WHAT YOU’LL NEED

Supplies

Sparkfun Supplies TTL
LilyPad Vibration board 1

LilyPad ProtoSnap Plus 1

USB Micro-B cable 1

Alligator Clips 3

Li-Po Battery 1

Computer capable of running Arduino software

Software
Current Arduino software found at www.arduino.cc
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CUP STACKING

ACTIVITY OVERVIEW
The students will gain the basic idea of programming by engaging 
in an “un-plugged” coding activity.  

Please see accompanying lesson plan for cup 
stacking activity. “Programming Unplugged: My 
Robotic Friends”

In this activity students, using a set of symbols in 
place of code, will design algorithms to instruct a 
“robot” to stack cups in different patterns. Students 
will take turns participating as the robot, respond-
ing only to the algorithm defined by their peers. 
This segment teaches students the connection be-
tween symbols and actions, the difference between 
an algorithm and a program, and the valuable skill 
of debugging.  The activity is free to download.

Please see accompanying lesson plan for cup 
stacking activity. “Programming Unplugged: My 
Robotic Friends”

https://curriculum.code.org/csf-1718/courseb/6/
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SET-UP

ACTIVITY OVERVIEW
The students will un-box their Sparkfun LilyPad ProtoSnap Plus 
development board in this computer programming lesson.  The 
students will establish a connection between their development 
board and computer.  They will also upload their first program.  
This first program uses many of the components on the 
development board.

Learning Objectives:
Students will be able to: 

■■ set-up the LilyPad ProtoSnap Plus by establish-
ing a connection between the computer and 
development board

■■ upload and run a program

Supplies needed for each student
■■  Computer
■■  Sparkfun LilyPad ProtoSnap Plus 
■■  1 USB Micro-B cable
■■  Engineering journals

Project Outline Time
Introduction 5 min

Set-up LilyPad ProtoSnap Plus 10 min

Vocabulary

board - the physical programmable circuit 
board

port - a physical connection to some other 
device

processor - responds to and processes the 
basic instructions that drive the computer

USB-Serial or COM - a USB connection  to a 
port used for communication through which 
information transfers in or out one bit at a 
time

ProtoSnap Plus development board 

a.k.a Dev board - the prototyping board 
made by Sparkfun that includes the simple 
board, four pairs of LEDs, buzzer, button, 
switch, a light sensor, plus extension ports
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The Development Board
The LilyPad ProtoSnap Plus development board is designed to get you started in the world of e-textiles. 
Combining a LilyPad Plus Simple Board with other LilyPad components like light sensor, a buzzer, a button, 
four pairs of colored LEDs, and a slide switch the ProtoSnap LilyPad development board lets students dive 
right into wearable electronics.  The Protosnap also includes expansion ports to connect external sensors 
and components to the board.

DON‘T snap apart the LilyPad ProtoSnap Plus until students are ready to use the pieces in a project. If  
the pieces are left attached to the board, students will be able to prototype and test their projects before 
sewing.

Parts and Pins of the Protosnap Plus Board
The Lilypad Protosnap Plus has twelve components connected to the microcontroller by conductive 
pathways called traces. Below is a diagram of the Protosnap Plus board.

II. The Protosnap Plus board communicates with the computer through the use of a USB port and a 
micro-B USB cable. At its core the Protosnap Plus board has a LilyPad USB Plus microcontroller with a 
built-in RGB LED and bar graph of LEDs, as well as two additional power (+) and ground (-) sew tabs for 
ease of use.  The LilyPad USB plus is shown below.

Features of the LilyPad Protosnap Plus:

■■ USB port for connecting to a computer.
■■ Two sets of power (+) and ground (-) sew tabs.
■■ Built-in RGB LED attached to pins 12 (R), 13 (G), and 14 (B).
■■ A row of six white LEDs attached to pins 15-20.
■■ Charging circuit for single-cell (3.7V) Lithium-Polymer batteries.

©SparkFun 2018

©SparkFun 2018
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Arduino

The LilyPad ProtoSnap Plus development board is programmed using a coding language called Arduino. 
Arduino is an open-source platform used for building electronics projects. In the following steps you will 1) 
install the Arduino program, 2) add the Protosnap board to the preferences and finally 3) add some code 
so that Arduino will recognize the board.  Arduino consists of both a physical programmable circuit board 
(often referred to as a microcontroller) and a piece of software, or IDE (Integrated Development Envi-
ronment) that runs on a computer, used to write and upload computer code to the physical board.  More 
infomation on Arduino is available from Sparkfun using the link below:
https://learn.sparkfun.com/tutorials/what-is-an-arduino

Step 1. Install Arduino
To start using the LilyPad ProtoSnap Plus download and install Arduino. Note: the board requires Arduino 
version 1.8 or higher so be sure to update the most current version if Arduino has already been installed.
Download and Install Arduino
1.	 visit URL: http://arduino.cc/en/Main/Software
2.	 download current version for your operating system
3.	 follow steps and procedures for installation based on your configuration and OS

For additional help with installing Arduino the link below:
https://learn.sparkfun.com/tutorials/installing-arduino-ide

Step 2: Add the board to the Arduino Preferences
Now that you have the Arduino program installed open the Arduino software on your computer.                
In Arduino, open the Preferences window by choosing File > Preferences from the menu.

In the “Additional Boards Manager URLs” text box type the following:
https://raw.githubusercontent.com/sparkfun/Arduino_Boards/master/IDE_Board_Manager/package_spark-
fun_index.json

The image below (left) displays the Additional Boards Manager URLs textbox.  If more room is needed 
click the button to the right of the box as shown in the right hand image below. This will open a window 
allowing you to type the URL onto a new line. Click OK when done.
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Step 3. Install SparkFun AVR Boards
In this step you will add the LilyPad USB Plus 
through Arduino’s Boards Manager Menu. Open 
the Boards Manager by choosing Tools > Board 
> Boards Manager… as shown in the image right.  
When the Boards Manager window opens, it will 
present a long list of options. Type “sparkfun” 
(without quotes) into the “Filter your search” box 
at the top of the window. This will shrink the list 
down to SparkFun’s options.
You should see several entries. Look for the one 
labeled SparkFun AVR Boards by SparkFun Elec-
tronics as shown on the right below.

Click anywhere in the SparkFun AVR Boards box. 
A version number and an “Install” button will ap-
pear. Click the install button. This will download 
and install the extension, once installed select the 
close button. If it is already installed, update to the 
latest version (LilyPad USB Plus and example code  
included 1.1.8 and higher).  For troubleshooting tips 
visit:  
https://learn.sparkfun.com/tutorials/
lilypad-protosnap-plus-hookup-guide?_
ga=2.233140382.1272845635.1526487639-
54715019.1523295674

Uploading Code
Now that the Arduino software has been installed students can be begin to upload code from their      
computers to the Protosnap Plus board. Youth will need to perform three steps every time they want to 
program the board. These three steps are:

1. Connect the LilyPad ProtoSnap Plus to the 
computer using a USB cable

2. Select “LilyPad USB Plus” from Arduino’s “Board” 
menu (pictured below)

©SparkFun 2018
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3. Select “LilyPad USB Plus” from Arduino’s “Port” menu (pictured right).  On Windows ports are listed as 
COM##; on a Mac or Linux machine they will be “/dev/cu.usbmodem####”

Slide the switch on the LilyPad USB Plus to the ON position. Students will not be able to upload code to 
the board if it is set to the OFF position.  Once plugged-in and powered on the board will light-up and 
cycle through the Yellow, Red, Green, and Blue LEDs as well the white LEDs on the board and the built-in 
RGB LED in the center of the board.

Uploading Code

When all the following have been completed students will be ready to upload their first program:

■■ Connected the LilyPad ProtoSnap Plus to the computer using a USB cable.
■■ Selected the board type (“LilyPad USB Plus” NOT “LilyPad Arduino USB”).
■■ Selected the COM port.
■■ Students are ready to upload code! Let’s upload some code to try it out:

©SparkFun 2018
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Load the “Blink” example from the menu File > Examples > 01.Basics > Blink, and click the “Upload” button 
(the large round button with the right arrow in it). This is a very simple example program; it just blinks a 
LED on and off once per second.

Arduino will compile the code, then send it to the LilyPad USB Plus via the USB cable. While the code is 
uploading, the built-in LED will blink to signal the code is transferring. When the code finally runs, the RGB 
LED at the center of the board will slowly blink green. Success!

Using the Expansion Ports

The LilyPad ProtoSnap Plus features five expansion ports connected to sew tabs on the LilyPad USB Plus. 
These allow you to easily attach external components to the board, including LilyPad and non-LilyPad 
boards. The expansion ports can accommodate alligator clips for testing and experimentation. 

©SparkFun 2018


