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VersaWorks Abnormal Termination or Lock up Troubleshooting Procedure

The most common causes for VersaWorks to crash or lock up can be attributed to the following:

1. VersaWorks not up-to-date

2. Incomplete or improper update
3. Corrupted jobs in the queue

4. Corrupted artwork files

Crashing or freezing may occur in the following circumstances.

During launch

When opening or closing Job Settings window
When changing settings in Job Settings window
When processing (RIPing/Printing) a file
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Randomly with no specific pattern

General Troubleshooting Steps

Step 1 — Making sure your computer meets the requirements to run VersaWorks.

The recommended computer configuration to run VersawWorks is:

Operating System | Windows XP Professional (32-bit), Windows Vista Business or Ultimate, Windows 7
Professional or Ultimate

CPU Dual Core or better, 2GHz or faster

RAM 2GB or more (4GB is strongly recommended if you run VersaWorks and design
application on the same computer)

Hard Disk 40 GB of free space on the disk Windows is installed

Monitor 1280 x 1024 or higher resolution

Network 100 Base T (Wireless network is not recommended)

USB Only needed when using VersaCAMM SP-300V or GX cutters
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Increasing the amount of RAM (4GB is recommended) is one of the most effective and inexpensive way to
enhance computer performance and stability as more memory becomes available for the operating system,
VersaWorks and other applications that are running concurrently. Since 64-bit versions of Windows (Vista or
7) can fully utilize larger amounts of memory (RAM), we recommend installing/upgrading to 4GB or more. 32-
bit versions of Windows (Vista or 7) cannot use the full 4GB memory space but you will still see improvement
in performance by upgrading to 3GB.

Also, keeping your computer and operating system up-to-date applying the latest system and driver updates
can also improve performance and reliability overall. VersaWorks interfaces heavily with memory, hard drive,
video and network interface cards. A faulty driver can cause frequent or random crashes, soit is a good idea
to keep them up-to-date.

Step 2 — Making sure VersaWorks is up-to-date

One of the most common reasons for VersaWorks to crash or freeze can be attributed to running an old
version of VersaWorks. A number of improvements in reliability were made in the past few versions and
everybody should update to the latest version. Any of symptoms listed in the beginning of this document can
show up when running outdated versions of VersaWorks. Please follow the steps below to update
VersaWorks.

1. Close VersaWorks and restart the computer. Restarting the computer will ensure that all files will be
updated correctly.

2. Go to Start > All Programs > Roland VersaWorks > Online Update.

] Marual Update A =)

Eile Settings Help

E Click "Check for updates" to connect to Roland@MNET server.

Details :
http:#/VersaWorks.rolanddga.com: 8080 /update info2/index4d html

3. Click on Check for updates

If this is the first time you are updating VersaWorks online on this computer, you may be prompted to

register your printer. Please complete the registration to be able to update VersaWorks.
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4. If your version of VersaWorks is not current, the Online Updater will list the items that need to be
updated.

You can reduce the size of download by clicking Details and deselecting media profiles that are not
relevant for your device.

Select updates Select Media
The following updates are available. Please check the Update Information before . . .
proceeding and then select the items to install. Select the media and profile updates to install
Device : Media :
¥ Roland Versawiorks Application Pragram 7iE MBE I YersaCarM N\ - YK

I~ SOLJET PROZ - ECO-S0L Mé CMYKLeLmiwht
‘ I~ SOLJET PRO3 8- ECO-S0L MAX CMYKLeLm
¥ Color Profiles 10297 MB [ ADVANCED JET
I~ SOLJET PRO3 w2
Total: 11033 MB I ‘ersaCamM VP
I Wersadrt

I ADWANCED JET
I WersaCamM VP i

Detail

hitp: ¢ versaworks rolanddoa com: 8080 update infoz/indzxd. himl

Update I Cancel

¥ ersaCamM VS

Cancel

5. Click Update and the updater will start downloading updates.
6. Click OK when downloading is completed to apply the updates.

7. Launch VersaWorks to apply the update. This is an important step as some updates are only applied
when VersaWorks is launched.

8. Close VersaWorks and go again to Start > All Programs > Roland VersaWorks > Online Update

and make sure there is no additional updates to your program. Proceed to update if it still shows more
updates to application program and device information.

9. Once all updates are applied, launch VersaWorks and verify if the crash still occurs. If the crash still
occurs, go to Step 3 — Initializing VersaWorks.
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Step 3 - Initializing VersaWorks

In some cases, a corrupted job in the queue or corrupted configuration file can cause VersaWorks to crash. In

this case, the crash may occur when launching VersaWorks or when processing a file in the queue. This issue

may also happen immediately after updating VersaWorks as the update may have not been applied correctly.

Whenever you experience repeated crashes, initializing VersaWorks can be an effective way to fix the

problem. Note that the following information will be cleared by initializing Versaworks:

1. Printer configuration — please take note of printer’s IP address before initializing VersaWorks. If you

can start VersaWorks, the IP address can be viewed in Printer Status windows. If VersaWorks does
not start, the IP address can be viewed from the printer menu by navigating to MENU > SYSTEM
INFO > NETWORK > IP ADDRESS. On some printers such as SOLJET PRO Il, VersaCAMM SP-
540V, AJ and FP printers, you will need a utility called Print Server NetTool to see the IP address

(NetTool is available for download from our support site).

Printer Status

Model Mame WersaCaMM WP-Bali

l Pt IP:172.16.14.20

Firrnware Yersion:  3.80

Serial Number : Z+B0186

Status : Secondary Pawer OFF
Media Width 1318.000

Ink Status :

K C M hd

Update(U] |

2. Preferences and Queue settings —if possible, take note of any special settings that you have done in

Preferences or Queue Settings, sothat you can replicate the same settings after Versaworks is
initialized.

Jobs in the queue — although initialization will not delete any design file, it will completely clear the job
gueue and you will lose any job specific settings that you have done. If you need to reprint any job in
the queue, save the job in .rvw format. Once VersaWorks is initialized and reconfigured, the .rvw file

can be reloaded to recover the job and the settings that were used for printing.
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Follow the procedure below to initialize VersaWorks:

1. Close VersaWorks
2. Go to Start > All Programs > Roland VersaWorks > Initialize Application
3. Click Yes and then OK.

4. Launch VersaWorks and enter the printer’s IP address or select USB if your printer is connected to a
USB port.

5. Verify if the crash issue has been fixed.

Crashing or freezing with a specific file

If VersaWorks crashes or freezes when processing a file make sure the file is one of supported formats in
VersaWorks. VersaWorks supports the following formats: .jpg, .tif, .eps, .pdf and .ps. If the file is saved in a
format not supported by VersaWorks, open the file in the design application and select Save as to save in one

of supported formats. Most of design applications allow saving in EPS or PDF formats.

If the file is one of supported formats, it is important to determine whether the issue occurs only with this

specific file or with any file.

If the crash/freeze occurs with any file including raster images such as JPEG, TIFF files, and other design

formats such as PDF, EPS and PS, the issue is most likely caused by some corruption in VersaWorks. Please
follow the procedure in Step 3 — Initializing VersaWorks to fix this problem.

If the crash occurs with one file in particular, the file itself is likely to be corrupted. Please follow the steps
below to troubleshoot the file:

1. Open the file in the design application.

2. Select all the objects from the design and press Ctrl+C to copy the entire design to the clipboard.
3. Create a new blank file.

4. Press Ctrl+Vto paste the design to the new file.

5. Go to File > Save (or Save as) to create a new copy of your design in one of the formats supported by

VersaWorks.

6. Load the new file in VersaWorks and verify if the steps above fixed the problem.
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7. If VersaWorks still crashes, try saving in a different format by executing File > Save As and selecta

different file format (if the original file was in EPS format, try saving in PDF format and vice versa).

8. Try also changing the PosScript version when saving. By default, lllustrator will use PostScript level 2
when saving the file in EPS format. Try changing this option to PostScript 3.

9. Another option is to save in .ps format by printing using RolandVVW printer driver and selecting Save
as File. Saving as PostScript file using the PostScript driver creates files that are simpler as the

PostScript driver takes care of converting complex effects to standard PostScript format.

Other Crashing or Freezing Issues

In some cases, you may see unusual error messages such as Runtime error or VersaWorks detects that
there is a newer version but it does not get updated. This issue is typically caused by problems during
VersaWorks installation or updating on computer running Windows Vista or 7. Windows Vista and 7 may
prevent the overwriting of files in Program Files folder in the following situations:

- User account does not have administrator rights

- Files are being used by an application (may happen when VersaWorks is not properly closed)

When this happens, Windows creates copies of these files under a hidden folder which may cause

VersaWorks to not update correctly and work erratically. Please perform the steps below to fix this issue:

1. Close VersaWorks.

2. Launch Windows Explorer.

3. Click Organize and select Folder and search options.

v | 3 [ Search Libraries

File Edit View Tools Help !

Organize ~ ||| New library 3=~ O @
Cut B - " i
. — Libraries
Copy Open a library to see your files and arrange them by folder, date, and other properties.
Paste L
Und & Documents ﬁ Music l
Redo < Library <&, by
;4 Pictures n Videos
R i Library 8 Library H

|I 4 iterns
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4. In Folder Options, click View and then check the option Show hidden files, folders, and drives.

T
Genemll VIBW' Search

Folder views
You can apply the view {such as Details or lcons) that
you are using for this folder to all folders of this type.

| Applyto Folders | [ Reset Folders

Advanced settings:

Files and Folders

[] Always show icons, never thumbnails
AMways show menus

Display file icon on thumbnails

Display file size ifformation in folder tips
[ Display the full path in the title bar (Classic theme only) |
Hidden files and folders
(1 Dopt show bidden filee foldere or drive
(@) Show hidden files, folders, and drives
Hide empty drives in the Computer folder

[ Hide extensions for known file types
Hide protected operating system files (Recommended)  —

Restore Defaults
G [ o

5. Click OK.

6. Still in Windows Explorer, navigate to C:\Users\{user name}\AppData\Local\VirtualStore\Program
Files(x86) folder if you are running 64-bit version of Windows or C:\Users\{user
name}\AppData\Local\VirtualStore\Program Files if you are running 32-bit version of Windows.

7. Delete the Roland VersaWorks folder from this folder.
8. Follow the steps in Step 2 — Making sure VersaWorks is up-to-date.

9. Check if you the issue has been fixed.

If you are still experiencing issues after all these troubleshooting steps...

If you are still experiencing random or persistent freezing and crashing issue even after performing all
troubleshooting steps described above, please contact Roland Technical Support. Please be prepared to
provide the following information when contacting Roland.

1. Printer’s Serial Number

2. Printer’'s Firmware Version

3. Version of VersaWorks (Go to Help > About VersaWorks)

4. Version of Windows Operating System (Windows 7 Professional 32-bit, Windows Vista Ultimate 64-bit,

Windows XP Professional, etc.)
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Control Panel + All Control Panel tems » System -

Il Eile View Tools Help

| Control Panel H . P . @
e View basic information about your computer

| % Device Manager Windows edition

|| ®) Remote settings ‘Windows 7 Professional

&) System protection Copyright © 2009 Microsoft Corporation. Al rights reserved.

%) Advanced system settings Service Pack 1
Get more features with a new edition of Windows 7

System
Rating: m\'\'mduws Experience Index
Processor: Intel(R) Core(TM)i7 CPU M620 @ 267GHz 2.67 GHz
Installed memory (RAM):  4.00 GB (3.86 GB usable)
Systern type: 64-bit Operating System
Pen and Touch: No Pen or Touch Input is available for this Display

Computer name, domain, and workgroup settings
Computer name: pmho B Change settings
Full computer name: pmho.roland.ad
Computer description:
Domain: roland.ad

See alsi

e Windows activation

Action Center . .

‘Windows is activated

Windows Update
Product 1D: 00371-0EM-8392671-00524

Performance Information and
Tools

Lean more online...

5. Computer information (brand, CPU, amount of RAM, free Hard Disk space)

6. Complete error message if VersaWorks or the computer displays an error message when the issue
occurs. It is always a good idea to capture the screen shot of any error message by pressing Print
Screen key in the keyboard and pasting on an e-mail message or on Windows Paint application and

saving as a bitmap file.

7. Detailed steps to duplicate the problem. If a specific design file is involved, we may ask to provide the
design file that causes VersaWorks to fail.
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