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General

Hint panel

Keep an eye on the hint/info panel at the top-left ProdSecrets Beat.flp -

corner of your screen. Whenever you hover over a . 1 @ Browser - All- s

control or feature it will display extra info and tips. * L < ‘
3 My projects

Save as a new version

Use Ctrl + N to save your current project as a new version. This is useful when you
want to try something different with a song, while still retaining the ability to revert

to the previous version.

Close all plugin windows

When working on large projects, it’s relatively easy for your screen to get filled up with
all kinds of plugin windows. Use Alt + F12 (Opt + F12) to close all plugin windows and
clean up your digital workspace.

Organizing plugins BT |  Phaser BI-TRON
= < - [iruitydziii:ce Frequency Shifter
FL Studio allows you to organize your plugin oundshifter Pitch Shifter
. . ADPTR MetricAB Vintage Chorus
list and create subfolders. This keeps you from Spechsaan _ L
RX 7 Breath Control
wasting time looking for a certain plugin. ox 0pto ety

bx_townhouse Buss Compressor

RX 7 De-hum
RX 7 Voice De-noise

Comp FEI-76
Purple Audio MC 77

Navigate to (on Windows): T

C:\Users\Username\Documents\Image-Line\FL Studio\Presets\Plugin database\Effects

OR

C:\Users\Username\Documents\Image-Line\FL Studio\Presets\Plugin database\Generators
Here you can organize your plugins and create custom folders for different types of

effects and instruments. Keep in mind that you can only have one ‘layer’ of folders
Inside of the ‘Effects’ and ‘Generators’ folders, so no folders inside of folders.
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Plugin shortcuts

: Chorus DI

FL Studi | to instantl luai O Fruity Balance Flanger B
UGIO allOWS YOU TO INStantlty open up piugins B o

by simply pressing a single key on your keyboard. 2 ValhallaVintageVerb Phaser BI-

3 Saturn 2

Frequency

. _ 4 SoundShifter Ditch Shift

First, make a selection of up to 10 of your teh Shitts

Vintage C

ADPITR MetricAB
Spectogram

most-used plugin effects and up to 10 of your

most- used plugin instruments. Navigate to the
folders from the previous tip. Add a number between 0 & 9 at the start of the file names of
each of the plugins. Make sure these plugins are in the main ‘Effects’ or ‘Generators’ folder

and not in a subfolder. Make sure there aren’t any other plugins or folders with names
starting with 0-9.

Now if you open the plugin list in FL Studio, you can simply press one of the number

keys on your keyboard and instantly open the plugin linked to that key. This trick can
be a real time-saver!

Quick export

Conventiently export your project as a lossless .wav file with Ctrl + R (Cmd + R) or as a lossy
.mp3 file with Ctrl + Shift + R (Cmd + Shift + R).

Duplicate

The default shortcut for duplicating in FL Studio is Ctrl + B (Cmd + B). This works on any
selection of notes or playlist clips and pastes the duplicate right next to the selection.

Reset value

Alt (Option) + click any knob or fader to reset its value to its default value.

Finetuning parameters

Hold Ctrl (Cmd) to finetune any parameter when adjusting. It allows you to get very precise results.

Audio monitor

B:ST

Right-click on the audio monitoring window at the top of your o [© Geiisgsge |
. . d  Pattern 1 e crogram [
screen to switch between an oscilloscope and a spectrogram .

- Rose Colored (

{— Long

Stereo

(frequency spectrum).
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Time counter

Right-click on the timer at the top of your screen to switch between bars and beats to
minutes and seconds.

Lock mute/solo

Shift + click on any mute button to lock its ‘mute state’. A locked mute ~ 0 -

button stays muted or unmuted if another channel is soloed. You can

' - 1 oma
lock automation lanes so they stay unmuted when you solo another '
channel.

Changing the metronome sound

The default metronome sound can be quite harsh on the ears when using headphones. You
can change it by right-clicking on the metronome icon and picking one of the four options.

Custom metronome sound

You can also set up a custom metronome sound.

Navigate to:
C:\Program Files\Image-Line\FL Studio 20\Data\System

*If you can’t find the ‘System’ folder you might need to turn on hidden items in the Windows
Explorer (‘View > Hidden items’). Replace any of the four metronome files with your own
one-shot .wav file. You might want to back up the original files first in case you ever want

to revert to the default metronome.

Miscellaneous

DetaChing plugins @ Auto name channels
(@) Auto name effect slots
The default metronome sound can be quite harsh on the ears © Auto zip empty channels
= . - - : @) Auto select linked modules
s s s 5 &) Small scrollbars in editors
the metronome icon and picking one of the four options.

(©) Alternate meter scale

@) Show startup splash screen

Productivity hack

If you use a mouse with programmable buttons, you can assign them to your
most-used FL shortcuts. This can have a significant impact on your workflow!
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Piano roll

Transposing notes

- Use Shift and arrow Up/Down to move selected notes up or down a semitone.
- Use Ctrl (Cmd) and arrow Up/Down to move selected notes up or down an octave.

Discard lengths

Resizing notes from the left

Use Shift and arrow Up/Down to move selected notes up ‘ Change color
Mute

Unmute

or down a semitone. Use Ctrl (Cmd) and arrow Up/Down to
move selected notes up or down an octave.

Piano roll - level scaling X

Note properties - E5 Center Multiply Offset

Batch editing notes T
- Use Alt +X (Option + X) to adjust the velocity level of el @ O( ‘#‘
. . PAN VEL REL M ! _!~

multiple notes at the same time. 04 ©r - -
- You can also select multiple notes and double-click . =

any note in the selection to edit more properties Start time 1:05:00

Tension
such as panning, velocity, and duration. puration 0:12-00

Reset ~ Accept

Reset Accept

Equalizing velocity values

Hold Shift and drag your cursor in the velocity panel to equalize note velocity level
(useful after recording MIDI).

Quantization

- Use Ctrl + Q (Cmd + Q) to quick-snap all selected notes to the grid.
- Alternatively, use Alt + Q (Option + Q) for more control .

Cycling through MIDI clips

Use Ctrl + K (Cmd + K) to cycle through the MIDI patterns from the instruments in your channel rack.

Grouping notes

Use Shift + G to group a selection of notes. When you resize or move a note that’s part of
a group, other notes in the group get affected as well. This can be a really useful feature
when you’re working with chords.
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Saving notes as MIDI

If you made a cool melody or chord progression but don’t know what to do with it right
now, you can save it for another moment. Use Ctrl + Shift + M (Cmd + Shift + M) to save
your pattern as a MIDI file. You can drag this file into the piano roll whenever you feel
Inspired. Exporting MIDI files can also be useful when you’re collaborating with someone
who uses a different DAW.

Chord stamps

Stamps are a way to add entire chords and scales with a single
click. Click the arrow in the top-left corner, go to ‘Stamp’ and
select a chord type or scale. It’s a quick and easy way to create

chord progressions and get the creative flow going!

Automatic key detection

Click the arrow in the top-left corner of the piano roll, go to ‘View > Scale highlighting’
and select ‘Automatic’. FL Studio now automatically detects the scale you’re working in
and highlights (light grey) the notes that are in the scale. Hover anywhere in the piano
roll and the detected scale shows up in the info display in the top-left corner. When
you’re looking for instrument loops or vocals, it’s important you know which key

you’re working In.

Fancy piano

While making this ebook we discovered it’s possible to change
the look of the piano keys in the piano roll. Click the arrow In
the top-left corner and go to ‘View > Keyboard style’. You can

£
el

choose between five different variations.

Flipping MIDI

When you’re stuck on a melody and need inspiration, use Alt + Y (Opt + Y) in the piano roll.
This opens up a menu where you can horizontally or vertically flip a selection of notes or
the whole score. This can lead to really creative and unique sounding results.

Time Machine

Played an awesome melody but forgot to hit record? Head over to ‘Tools > Dump
score log to selected pattern’ and click one of the options listed. This will recover
all MIDI input from the last 2-30 minutes.
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Mixer

Batch editing mixer tracks

- Hold Ctrl (Cmd) and drag your mouse to select multiple mixer tracks next to each other.
Hold Ctrl + Shift (Cmd + Shift) to select and deselect individual mixer tracks.

- Use Alt + S (Opt + S) to solo all mixer tracks in a selection.

- Right-click on any of the selected mixer tracks to batch-edit names, change colors, and
add icons.

- Adjust the volume of multiple mixer tracks simultaneously by selecting them and dragging
one of the faders up or down. At the time of writing, scrolling when hovering above a fader
to adjust the track volume only works for individual tracks, not on selections.

Routing

You can ‘send’ audio from one mixer track to another by clicking the
arrow under the track you want to send the audio to. Right-clicking
this arrow gives more options.

Separators

Use separators between mixer tracks (Right-click > Separator) to define sections for
different categories of instruments and sounds.

Docking mixer tracks

Right-click on a track, hover over ‘Dock to’, and choose left or right. This moves a mixer
track all the way to the left or right of the mixer panel and sets it apart. This can be useful
to create reverb or delay sends, instrument groups, or tracks for parallel processing like
compression.

Saving effects chains

Right-click on a mixer track and click
‘File > Save mixer track state as...’ to save a whole mixer

track including all insert effects on your computer. | oot

Dual joypad control

Bonus tip: drag the ‘Save mixer track state as...” text to an empty mixer track and FL Studio
will create a duplicate of the track with the exact same settings and plugins.
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Resetting mixer tracks

Right-click on a mixer track and click ‘File > Default’ to reset it to its default value.
This will remove all plugins and reset all controls. Keep in mind that any sends need

to be removed manually.

Moving mixer tracks

Hold Alt (Opt) and use the left/right arrows on your keyboard to move any selection of
mixer tracks to the left or right.

Fruity Balance for automation

We highly recommend using Fruity Balance for volume and

panning automation. Automating the volume and panning

controls on the mixer itself will deprive the possibility to tweak o

. 39
the controls later on. Any changes made to the controls will be (entered 0.0aB 1.00

overruled by the automation.

Stereo width control

The mixer in FL Studio has a built-in stereo separation knob at the bottom of every mixer
track. To make sure it’s enabled head over to the top-left corner of the mixer and click the
third icon next to the arrow. The icon will turn blue when checked.

group
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r
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Playlist

Adding time markers

Use Alt + T (Opt + T) to add markers to the playlist. Markers are an incredibly helpful tool
to set loop points and indicate different song sections.

Mute tool

Use the mute tool to mute clips in the playlist. I1t’s nice to be able to mute a sound without
having to completely remove it from the arrangement.

MUItlple arrangements -‘u d» Playlist - Arrangement v Cymatics - Rc

FL Studio allows you to have multiple arrangements inside & L]

strercn () v Arrangement 5

a single project. Click the word ‘Arrangement’ at the top

Clone...

Rename...

of the playlist window. A menu will pop up that allows ®
you to clone the current arrangement or add a new blank

Add one...

one. I’'ve personally found this feature to be very useful ®
when trying out different arrangements and song structures.
It’s super convenient to A-B compare multiple options and pick the one that sounds best.

Auto chop samples

A cool way to flip samples is to chop them up and rearrange them. You can make FL
Studio chop samples for you right in the playlist. Right-click on a sample you want to chop
(on the waveform icon in the top-left corner), head over to ‘Chop’, and choose any of the
patterns and rhythms. Feel free to experiment until you find a rhythm that works well.

Declicking modes

Chopping audio may cause clicks at the cuts. You can prevent this from happening by
selecting a ‘Declicking mode’ in the sampler. Make sure to pick one with bleeding.
This creates short fades at the cuts. See below a short explanation of the declicking modes:

Out only (no bleeding) - No in-declicking, declicking-out is a 10ms fade-out.
e Smooth (bleeding) -

Transient (no bleeding) - VERY short fade-in and short 10ms fade-out.

Out only (no bleeding)
Transient (bleeding) - Same as above, with a 20 ms fade-out. Transient (no bleeding)

Transient (bleeding)
Generic (bleeding) - 20ms fade-in and fade-out. g
Smooth (bleeding) - 100ms fade-in and fade-out.

Crossfade (bleeding) - 200 ms fade-in and fade-out.

Generic

(bleeding)

Crossfade (bleeding)
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Channel rack

Copy & paste MIDI between channels

You can cut, copy, and paste MIDI scores right from the channel rack. Click the little grey

square on the left of the sequencer to select a channel and use your regular clipboard
shortcuts Ctrl + X/ Ctrl + C/ Ctrl + V(Cmd + X/ Cmd + C/ Cmd + V) to cut, copy and
paste MIDI scores between different instrument channels.

Swing knob

Does your beat feel lifeless and stiff? Try the swing knob at the top of the channel rack
window. It’s easy to go overboard with this effect, but when done right it can add a lot of
life to a song.

Graph editor - QpChannelrack < w X
i RGBT
Click the chart icon In the top-right corner of the channel bl | 055EEEEEE E 5EE
rack window to open the graph editor. This allows you to — 1.8.0.0.9.0.0.0J0
spice up your drum rhythms by tweaking parameters like — .

velocity, panning, and pitch values. I I I I I I I I
Track 5

ote Vel Rel Fine Pan X Y Shift

Extending the loop length

You can extend the length of the step sequencer loop simply by clicking and dragging the
border on the right side of the panel.
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Miscellaneous

Noise reduction

FL Studio’s audio editor Edison has a built-in

noise reduction tool. Open up Edison by

pressing Ctrl + E (Cmd + E) while the mixer
panel is active. Now record or import the
audio you want to reduce the noise of into

Edison. After importing the file, select a part

of the audio that ONLY contains noise and
right-click on the toothbrush icon. This will

acquire a noise profile for the audio file. Now zoom out so you can see the whole waveform
from beginning to end. Press Ctrl + A (Cmd + A) to select it and click on the toothbrush icon.
This will open up a window where you can tweak settings and apply the noise reduction by
clicking Accept’.

Convert audio to MIDI

Edison has the ability to convert any melodic piece of audio into MIDI. This can be
Incredibly useful when you have a melody loop you really like but want to play it with a
different instrument. To do this, import or record a piece of audio into Edison. Click the
wrench icon in the toolbar and select ‘Convert to score and dump to piano roll’. This will
convert the audio to MIDI and paste it into the active pattern. The conversion isn’t perfect,
but it gives you a good starting point to find the right notes.

Drum shaping

A quick and easy way to shape drum one-shots is by using fades in the sampler. Make sure
‘Normalize’ is turned on, so the volume of the sample stays consistent. Use the ‘In’ and ‘Out’
controls to shape the attack and sustain of the sample. Use the ‘In’ knob to emphasize the
sustain of the sample. Use the ‘Out’ knob to reduce/shorten the sustain.

Reverb ambiance

You can turn any melodic sample or instrument into a lush ambiance sound using Fruity
Convolver. First, send the sample you want to turn into ambiance to an empty mixer track.
Add an instance of Fruity Convolver and load the ‘Blur Pink’ preset (the preset browser is in
the top-right corner of the plugin window). Bring the ‘Dry’ knob all the way down and turn the
‘Wet’ knob up to 100%. This type of ambiance might work well in the background of an intro or
breakdown section. You can choose to export the ambiance to audio to get more control over
It or use it in another project.
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