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Introduction 
 
Having problems with your printing?  Are your gray tones coming out green or purple? 
There is no ICC profile available for your ink and paper combination?  You’re in the right 
place!  
 
Before you order a custom ICC profile, it’s best to ensure your software and printer are 
configured correctly for optimal performance. Follow this ICC guide to ensure your 
printer has the correct settings for desktop printing. 
 
If you have -any- questions, please contact us at Support@thePeridotPig.com . We 
recommend that you print out this document and the checklist to ensure you’ve 
completed all the steps -before- you order a custom profile. 
 
Before we get started: 

● Each of the following sections will have a checklist for you to complete. We 
recommend that you print this document and use it to ensure you complete all the 
necessary steps. 

● Turn off automatic software updates on your computer. We also advise that you 
wait a couple months after major OS updates to ensure all your applications will 
work with the new OS.  

● DO NOT allow automatic updates to your Epson print drivers! Do not rely on the 
version that came with your printer. Make sure you’ve downloaded the latest driver 
from the Epson site and have it properly installed. If your drivers or RIP (raster 
image processor software) change, your previous printer profiles, including custom 
ICC profiles, may no longer work. Changes to the software can affect the different 
color curves and mapping. If you find that you’re having issues after a software 
update, try reverting to the previous version to see if the problem is solved. 

  

https://theperidotpig.com/pages/custom-icc-profiles
mailto:Support@thePeridotPig.com
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Printer Maintenance 
 
Before you start printing, we want to make sure your printer is in an optimal state. Use 
the checklist below to make sure each item is covered. Instructions are provided for each 
step. 
 

□ Verify the printer driver version 
□ Check ink supply levels 
□ If needed, upgrade to the latest print driver and fill your ink cartridges 
□ Check the Print Head Alignment 
□ Perform a Nozzle Check 
□ If needed, perform a Head Cleaning 
□ Load the paper you intend to use for the custom profile 

 
Verify the Printer Driver Version 
 
If you already notice that you have problems with the basic CMYK colors, the first thing to 
check is your printer driver. Check your printer’s manufacturer website and download the 
latest version of your printer driver. Don’t rely on the version that came with the printer. If 
you are having color problems, you should first try to uninstall the driver and reinstall the 
latest version. 
 
Mac Users: Apple and Epson don’t always play well. You’ll need to ensure that you don’t 
have the Apple AirPrint driver installed instead of the Epson OEM driver. The AirPrint 
driver CANNOT be used to print the Target Images and will not work properly with any 
selected ICC profiles. 
 
We also recommend that you do not use your printer wirelessly. Even though you have 
installed and selected Epson drivers, you may not get the full functionality and may not 
fully switch off “Printer Color Management”.  Invest in a USB cable and connect to your 
printer for creating your prints and the Target Image in this process. 
 
Windows Users - Instructions to verify your printer driver: 

1. From the “Start Menu”, type in “control panel” and click on the “Control Panel” app 
2. On the top right under “View By”, click the triangle and select “Category” 
3. Then under “Hardware and Sound”, click “View devices and printers”  

https://theperidotpig.com/pages/custom-icc-profiles
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4. Select your printer from the list, right click to select “Printer properties”  

 
5. On the pop-up menu, select the “Version Information” tab  

6. Note the version shown and verify that it is the latest driver from the printer 
manufacturer’s website. 

https://theperidotpig.com/pages/custom-icc-profiles
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7. If needed, follow the manufacturer’s instructions to upgrade your driver to the 
latest version. 

 
 
Mac Users - Instructions to verify your printer driver: 

1. Go to “System Preferences” and open “Printers & Scanners” 
2. Select your printer from the list of printers shown 
3. Click the “Options & Supplies…” button 
4. Under the “General” tab, you should see your Device Name and the Driver Version 
5. If you see “AirPrint” on this page, you’ll need to switch to the latest OEM driver for 

your model. Visit the Trouble Shooting guide to resolve this issue. We cannot make 
a working custom profile if you are using AirPrint. 

 
Mac Users - Instructions to install the latest printer drivers: 

1. Download the latest driver software from the Epson support site. DO NOT 
download from Apple. Save a backup copy of your download. 

2. Return to the “System Preferences” -> “Printers & Scanners…” menu and delete all 
the existing versions of your printers. Select each and use the “-“ (Minus sign) to 
remove them. 

3. Remove all Epson printing applications and utilities from the “Applications” folder 
on your Mac.  

4. Install the new Epson driver package that you downloaded 
5. Connect your printer using the USB cable and turn it on 
6. Return to the “System Preferences” -> “Printers & Scanners…” menu and add a new 

printer using the “+” (Plus sign). You may have to wait a few minutes for the 
software to detect the printer and for all the drivers to appear. Some of these may 
be the Apple or AirPrint drivers. Wait for the correct driver to appear and select it. 

 
 
Check the Ink Levels, Head Alignment & Nozzle 
 
Windows Users - Instructions to verify your ink levels: 

1. From the “Start Menu”, type in “control panel” and click on the “Control Panel” app 
2. On the top right under “View By”, click the triangle and select “Category” 
3. Then under “Hardware and Sound”, click “View devices and printers”  

https://theperidotpig.com/pages/custom-icc-profiles
https://theperidotpig.com/pages/trouble-shooting-sublimation-printing
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4. Select your printer from the list, right click to select “Printing preferences”  
5. When the menu opens, click on “Ink Levels”  

6. Verify that all ink levels are high enough to print numerous color charts  

https://theperidotpig.com/pages/custom-icc-profiles
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Mac Users - Instructions to verify your ink levels: 
1. Go to “System Preferences” and open “Printers & Scanners” 
2. Select your printer from the list of printers shown 
3. Click the “Options & Supplies…” button 
4. Select the “Supply Levels” tab 
5. Verify that you have sufficient ink levels to print out the Target Images. If you’re 

getting low, fill up your inks before starting. 
 
Instructions to perform a Print Head Alignment: 
We’ve included the instructions for our Epson WF-7720 and it should be similar to other 
models. Consult your printer manual if you have a different printer model. 
 

1. Load a few sheets of regular copy paper and make sure there are no errors or 
notices on the main display 

2. Go to the “Maintenance” menu and select “Print Head Alignment” 
3. Select “Vertical Alignment” to start 
4. Follow the on-screen instructions to print the alignment sheet. DO NOT cancel 

printing while you are printing the head alignment patterns. 
5. Complete the vertical validation and then repeat the steps and perform the same 

check for “Horizontal Alignment”. 
 
Instructions to perform a Print Head Nozzle Check: 

1. Load a few sheets of regular copy paper and make sure there are no errors or 
notices on the main display 

2. From the “Maintenance” menu, select “Print Head Nozzle Check” 
3. Select “Start” and allow the pattern to print. 
4. Check the pattern: 

https://theperidotpig.com/pages/custom-icc-profiles
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5. If there are no gaps and the image looks like the one on the top, select “O” 
6. If there are ANY gaps or the pattern is faint, select “X” to continue 
7. Follow the instructions to clean the print head. DO NOT attempt to print the Target 

Image if there are print nozzle issues. Those issues must be resolved before 
profiling. 

 
Instructions to perform a Print Head Cleaning (only if needed): 

1. Load a few sheets of regular copy paper and make sure there are no errors or 
notices on the main display 

2. From the “Maintenance” menu, select “Print Head Cleaning” or continue from the 
failed Print Head Nozzle Check 

3. Select the appropriate option based on how your Nozzle Check looked. In the 
example above, you would select “All Colors” 

4. Select “Start”. DO NOT cancel printing, open the front cover or turn off the machine 
while you are cleaning. You might not be able to print. 

5. When the cycle completes, you’ll be prompted to perform another Nozzle Check. 
Select “Yes”. 

6. Select “Start” to print the Nozzle Check pattern. If it looks good, you’re all done. If 
there are still gaps, check your manual on how many times you can execute the 
cleaning cycle before having to let it rest. For some models, you can only clean the 
head 3 or 4 times before needing to let the printer rest for 6 – 12 hours.  

 
 
Finished with the checklist above?? Your printer should be in good shape. Now onto the 
print settings! 

  

https://theperidotpig.com/pages/custom-icc-profiles
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Printing Setup 
 
We’ve also included our recommended settings for printing. Even without a custom ICC 
profile, they will improve your print quality. You may have to experiment to find the right 
combination of settings for paper type. Save and label each of these print setting 
combinations as a Preset so that you can match it to your custom ICC profile. 
 
Printing Recommendations: 

● Use the correct weight of paper. Use the following paper weights for different types 
of images:  

o 125g paper for heavily saturated prints  
o 120g paper for medium/slightly heavy prints 
o 105g for fine print and light/medium saturation. 

● Don’t use the “plain paper” setting in your Print Settings. It can introduce additional 
color management and should only be used when you’re printing on regular copy 
paper. Use “High quality plain paper”, “Epson Matte” or “Premium presentation 
matte”.   

● Under “Print Settings” -> “Print Quality”, select “Fine” or “Quality”. Using “Quality” 
might give you too much ink saturation depending on your paper type and how 
well it absorbs the ink.  

● Turn off high-speed printing 
 
Windows Users – Printer Settings: 

1. Open one of your print files. 
2. Then select the “Print…” button and select “Properties…”  
3. Click the “More Options” tab  

https://theperidotpig.com/pages/custom-icc-profiles
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4. On the “More Options” tab, turn off “High Speed”. “Mirror image” should only be 

turned on for sublimation.    
5. Save this configuration as a preset, select “Add/Remove Presets…” 
6. Give the preset a name (we used “CustomICCProfile”) and click “Save”  

https://theperidotpig.com/pages/custom-icc-profiles
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7. Close the preset menu 
8. You’re now ready to create a test print. Select “OK”  

 
 
Mac Users – Print Settings: 

1. Open one of your print files 
2. Select “File” -> “Print…” but don’t press “Print” yet! 
3. Open the “Advance Setting” by clicking the “Show Details” button. 
4. Confirm that you have the correct Printer model selected. 
5. Select each of the center dropdown menus and check the following settings. The 

names will vary by model, but you should see menus similar to “Layout”, “Print 
Settings”, “Quality & Media”, “Color Matching”, “Paper Handling”, etc. 

6. Paper or Media Type: Select the items that you’ll be using with this profile and 
matches your chosen paper. You must select the appropriate “Media Type” and 
“Print Quality” 

7. Print Settings: deselect “Mirror Image”. It’s used for sublimation but not regular 
printing. 

8. Save these settings as a preset and/or write them down. You’ll want to use the 
same configuration with your new custom ICC profile.  
 

https://theperidotpig.com/pages/custom-icc-profiles
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Photoshop Settings 
 
Photoshop is one of the most useful programs for creating your prints. It allows you to 
specify your ICC profiles, color spaces and check for colors that will not print well.   
 
Configure the Working Space 

1. Open Photoshop, create a new project and configure the settings below: 

 
2. You can pick any size of document that will work with your image. You should use 

“ProPhoto RGB” for the Color Profile to give you the maximum range of color 
options. 

3. If you already have an existing image, open that file.  
4. Go to Edit -> Color Settings… 

https://theperidotpig.com/pages/custom-icc-profiles
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5. Set your Color Settings as shown above 
a. Under RBG, select “ProPhoto RGB”  
b. “CMYK:” should be “U.S. Web Coated (SWOP) v2” 
c. Check all of the profile mismatches boxes 
d. “Engine:” should be “Adobe (ACE)” 
e. “Intent:” should be “Relative Colorimetric” 
f. Save these as a Custom by selecting “Save…” and giving it a name. 
g. This will set your “color working space” to ProPhoto RGB. 

6. If you have an image that has a different color profile, you can convert it to 
ProPhoto RGB by the following steps: 

a. Select “Edit” -> “Convert to Profile…” 
b. Under “Destination Space”, select “ProPhoto RGB” for printed images. If you 

are creating images for digital or web use, select “image P3” 

https://theperidotpig.com/pages/custom-icc-profiles
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c. Make sure the “Flatten Image to Preserve Appearance” box is NOT checked! 

 
d. The next screen will pop up. Select “Don’t Rasterize” 
e. You are now working in a color space optimized for maximum printable or 

digital color. 
 
Setup Color Proofing 
 
Once you’ve set your color working space, you can now check to see if the colors in your 
image will print accurately. Use the following steps to set up Color Proofing: 
 

1. Select “View” -> “Proof Setup” -> “Custom…” 
 

2. Under “Device to Simulate:” select the ICC Profile that you will be using to print 
3. Select the “Rendering Intent:” you want. Normally “Relative Colorimetric” is best for 

sublimation. For regular printing try each to get the desired outcome. 
4. Select “Black Point Compensation” unless your ink manufacturer does not 

recommend. You can also select the simulation of paper color and black ink. 
5. You can save this as a preset and then click “OK” 

https://theperidotpig.com/pages/custom-icc-profiles
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6. Go to Photoshop -> Preferences -> “Transparency and Gamut…” 

 
7. Select the box to the right of “Color:” and pick a color that is very different from your 

image. In this example, we’re using a bright pink.  
8. Leave the “Opacity:” at 100% 
9. Click “OK” 
10. Go back to your image and select “View” -> “Proof Colors”. A check mark should 

appear to the left of “Proof Colors” 
11. Then select “View” -> “Gamut Warning”. A check mark should appear to the left of 

“Gamut Warning” 
12. You will now see bright pink in the areas where the color is outside of your printer’s 

capabilities. 

https://theperidotpig.com/pages/custom-icc-profiles
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Selecting Colors for Print 
 
As you create your design, check the colors to make sure they are in gamut or web safe.  
 

1. In the color picker, choose a color that is out of gamut with the eyedropper. 
2. Select the color, and look for either a triangle warning or a 3D box over the color 
3. The Triangle with Exclamation point warning is letting you know the color is out of 

gamut for your specified ICC profile. If you click the warning triangle, it will suggest 
an in gamut color. 

4. The 3D box shows that the current color is not web safe either. Web sites and older 
monitors might not render it correctly.  

5. You can select the “Only Web Colors” box but that will constrain you to a selection 
of colors that is smaller than your desktop printer can print.  

 
 
 
 

https://theperidotpig.com/pages/custom-icc-profiles
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