
IMPORTANT: To reduce the risk of fire, bodily injury, and damage to the
equipment, read through Instruction Manual before operating ESC and
always follow all instructions.

KEEP OUT OF THE REACH OF CHILDREN.
Pay attention to the maximum voltage allowed:

KDE-UASUVC Series 14.8V (4S LiPo) - 60.9V (14S LiHV) 63V Max.
If model is not listed, maximum voltage is stated in specifications.
Operating outside of the listed voltage voids warranty.

The KDE UVC Series are opto-isolated and do not provide BEC power output for
the peripheral equipment and requires 5 to 12V applied to the control lead.
Never operate the ESC beyond the specifications stated on hardware. Serious
injury or property damage can result from misuse.
Ensure the polarity is correct with the power supply to the ESC power source
leads. Reverse polarity may cause fire and serious injury and will immediately
damage the ESC beyond warranty coverage.
Ensure the ESC is installed in a safe location and protected to prevent any
exposed connections and solder-locations from contacting conductive areas.
Always use electronics-grade solder and make sure to use proper soldering
techniques and equipment. Poor soldering technique is a common cause of in-
flight failure and ESC damage. Ensure all connectors are protected with
insulation, such as heat-shrink, to prevent unwanted conduction and shorts.
Check all connectors for secure connection before flight. Disconnection due to
vibration and flight-conditions can result in a dangerous loss of control and
potential damage and serious injury.
Do not disassemble or open the ESC. Opening of the case or removal of shrink-
wrap may cause damage to the internal components, void all warranty claims,
and yield unsafe operation.
Install the ESC in a location with adequate airflow to maintain cool temperatures
and achieve the maximum performance rating
An electric motor that is connected to the ESC can start unexpectedly and can
cause serious injuries. Always remove the propeller and disengage all gearing
when working on the system with power applied.
KDECAN protocol documentation can be found online under the Manuals &
Models Tab on the KDE Direct UVC ESC Product Page

Do not allow full submersion of the ESC in water. Water can damage the ESC
and cause malfunction and failure of the electrical components.
KDE Direct is not responsible for the use of this Product(s) or for any
damages or injuries caused or sustained by its usage. Always observe all
laws and instructions regarding the use of this Product(s), and operation of
devices using this Product(s).
This is a high-power, electromechanical device with the potential to be very
dangerous – always handle with caution and be aware of proper operation.
This product may contain chemicals known to the State of California to cause
cancer and/or birth defects or other reproductive harm. Do not ingest or
attempt to ingest this product.
Disconnect brushless motor from ESC motor leads before programming ESC.
An electric motor that is connected to the ESC can start unexpectedly and
cause serious injuries or damage.
Before flight, ensure that all ESCs are operating on the same settings and
firmware.
Extending the ESC power leads is at your own risk and voids the warranty.

REVISION PR10

For the latest instruction manual revisions, software updates, liability
policy, and warranty information, visit the KDE Direct website at:
https://www.KDEDirect.com.

All technical inquiries, review the KDE Resource Center.

Pay close attention to proper wiring as shown in the diagram above. Ensure the
polarity is correct and proper soldering techniques are used when connecting
the power source and brushless motor to prevent damaging the ESC.

The ESC Series is specifically designed and optimized for the KDE Direct
UAS Brushless Motor Series; taking advantage of the new technologies and
specific algorithms for maximum efficiency and thrust generation.

Firmware updates and advanced programming capabilities are available
via the onboard micro-USB port, and accessed through the included PC-
USB cable with the KDE Device Manager Software.

ESC INSTALLATION AND WIRING

(-) TO POWER SOURCE
(BLACK POWER LEAD)

TO FLIGHT CONTROLLER
(BLK-R-W CONTROL PINOUT)

TO BRUSHLESS MOTOR
(BLACK MOTOR LEADS)

(+) TO POWER SOURCE
(RED POWER LEAD)
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https://cdn.shopify.com/s/files/1/0496/8205/files/KDECAN_Bus_Protocol_1.0.0.pdf?11895809671989535815
https://www.kdedirect.com/
https://www.kdedirect.com/pages/technical-support-center
https://www.kdedirect.com/collections/uas-multi-rotor-brushless-motors
https://www.kdedirect.com/collections/uas-multi-rotor-electronics/products/kde-dms?page=specs


The UAS ESC Series is optimized for the KDE Direct UAS Brushless Motor Series
and will not require additional programming for most flight applications.
Throttle calibration is not required – the ESCs are factory-calibrated and the
proprietary control algorithm will dynamically adjust to the receiver (RX)
and/or flight controller for simple plug-and-play operation. If manual throttle
calibration is desired, this option can be selected via the KDE Device Manager
Software in addition to alternate Advanced Settings available.

1. Ensure the ESC control lead is connected to the throttle channel on your
receiver (RX) or flight controller, confirming correct orientation of plugs.

2. Turn on the transmitter (TX) and set the throttle-stick position to zero or
low (0% throttle signal) to arm the ESC circuitry.

3. Connect the battery or power system to the ESC power source leads. The
ESC will remain disarmed until a 0% throttle signal is received. An arming-
tone will be heard and the number of LiPo battery cells will be heard as
individual tones, followed by additional and final arming tones.

4. If arming tones are not heard, adjust the transmitter throttle end-points
(ATV/AFR) values until the arming sequence is heard. Check the operation
of the ESC with the receiver (RX) throttle channel for correct direction and
reverse if necessary (reverse direction for Futaba systems).

If the arming throttle signal (0%) is not applied when the power
source is first connected to the ESC, short tones will continuously
sound after approximately five (5) seconds. To remove this
warning tone move the throttle to 0% or disconnect power.

5. Check for proper rotation direction of each ESC/motor combination. To
change rotation direction, swap ANY two brushless motor lead connections.

ESC PROGRAMMING AND OPERATION

REVISION PR10

ESC PROGRAMMING AND FIRMWARE UPDATE

1. Download the latest production firmware file (make sure to choose the
appropriate version for your ESC model) from the KDE Direct website at:

www.kdedirect.com/products/kde-dms

2. Update the ESC to the latest production firmware release by pressing the
“UPDATE FIRMWARE” button in the Device Manager software and selecting
the downloaded firmware file (.kde).

Do not disrupt power or connection to the ESC or PC during the
update process, or corruption of the firmware and permanent-failure
of the ESC can occur (6ESC can be restored in most cases via the
“REPAIR MODE” feature).

3. When update is completed, the default settings will be automatically applied
to the ESC and confirmed (allow up to five (5) seconds for this to complete).

- Optimized settings will be applied to the ESC, and no additional changes
are required for correct operation with the KDE Direct UAS Multi-Rotor
Brushless Motor Series for UAS and multi-rotor applications.

- Default Settings can be reloaded by pressing the “DEFAULT SETTINGS”
button, followed by pressing the “SEND SETTINGS” button in the Device
Manager software (allow five (5) seconds to pass before unplugging).

4. Disconnect the Micro-USB cable from the ESC to complete the update.

3         4

1. Download and install the KDE Device Manager Software from the KDE Direct
Device Manager Software webpage at:

www.kdedirect.com/products/kde-dms

2. Complete installation of the software (and all prerequisites), and run the
KDEDevice application from the Windows start menu or desktop shortcut.

3. Connect the Micro-USB cable to an available PC-USB port.

4. Connect the Micro-USB cable to the ESC, pulling back the weather-proofing
grommet and accessing the available Micro-USB port.

- Detection of the ESC via the Device Manager software may take up to
five (5) seconds to properly boot the internal microprocessor and
download current settings.

DEVICE MANAGER SOFTWARE INSTALLATION

The KDE Direct Device Manager provides the ability to update and
program the KDE Direct UAS Brushless ESC Series to the latest production
firmware releases, and customize advanced options for multiple
applications. Advanced technologies, such as Synchronous Rectification
and Regenerative Braking, can be enabled for enhanced performance and
optimized control algorithms. All ESCs on a system need to operate on the
same firmware version and settings.

MICRO-USB PORTDUAL CAN BUS PORTs

The UAS ESC Series come equipped with two CAN bus ports in addition to the
USB port for connection to the KDE Device Manager. The CAN bus connections
use a standard CAN bus cable.

ESC CONNECTION PORTS

https://www.kdedirect.com/collections/uas-multi-rotor-brushless-motors
https://www.kdedirect.com/products/kde-dms?page=specs
https://www.kdedirect.com/products/kde-dms?page=specs
https://www.kdedirect.com/collections/uas-multi-rotor-brushless-motors
http://www.kdedirect.com/products/kde-dms?page=specs
https://www.kdedirect.com/collections/uas-multi-rotor-electronics/
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DRIVE FREQUENCY

PRECISION
(30 kHz – 32 kHz)

Fastest PWM drive frequency to the motor, providing the 
smoothest/quietest operation (increases ESC temperature).

DYNAMIC
(16 kHz – 18 kHz)

Dynamically adjusts the PWM drive frequency to the motor, 
providing the best overall balance of performance.

BALANCED
(8 kHz – 10 kHz)

Lowers the PWM drive frequency to the motor, reducing ESC 
temperatures (increases motor commutation noise).

SYNCHRONOUS RECTIFICATION (ACTIVE-FREEWHEELING)

ENABLED
Enables synchronous rectification (also termed active-
freewheeling) for improved efficiency and regenerative braking 
algorithms ideal for UAS and multi-rotor operation.

DISABLED
Disables synchronous rectification for improved light-loading 
operation (such as motor bench-testing) and minimal-brake 
activation ideal for specific single-rotor applications.

S.R. BRAKING ACTIVATION (REGENERATIVE-BRAKING)

PRECISION
Enables synchronous rectification immediately, ideal for FPV 
racing and light multi-rotor applications.  Provides immediate 
response at spool-up and flight take-off.

DYNAMIC
Enables synchronous rectification upon reaching optimal ESC 
temperatures, allowing for smooth operation during initial 
motor spool-up and flight take-off.

BALANCED
Enables synchronous rectification upon reaching higher ESC 
temperatures, allowing for smooth operation during initial 
motor spool-up and further into initial flight.

STARTUP POWER

DYNAMIC
Dynamically adjusts to the startup-requirements of the motor, 
optimal for most setups and KDE Direct brushless motors.

HIGH (HARD)
Increases the startup-power for high-cogging torque motors or 
high-stall loading setups.

NOTE: The Device Manager Software allows for modification of control
algorithms and tuned ESC operation – in rare instances will the Advanced
Settings need to be changed for proper UAS and multi-rotor flight application.
* Bold indicates default settings

ESC PROGRAMMING AND ADVANCED SETTINGS

The UAS UVC series ESCs have advanced technologies including:

• Controller Area Network (KDECAN) – digital CAN multiplex serial-bus
control, allowing for direct motor control and live-telemetry feedback to the
flight-controller for superior safety and operation. KDECAN Protocol

• IP66 Rating – ingress protection 66 rating for all weather and dust-proof
operation, providing complete protection against contact with external debris
and projected water (heavy-rain) and snow conditions.

• Anti-Spark Circuitry and Short-Circuit Protection – ESC incorporates a
live-MCU controlled anti-spark circuit, preventing connector sparks during
initial plug-in of batteries and protection against external short-circuits.

• Active Monitoring – internal hardware and specialized algorithms
continually monitor voltage, current, temperature, throttle signal integrity,
and a host of other critical parameters for safe and reliable operation.

• Overcurrent Protection – ESC incorporates a real-time, fast-logic
monitoring of incoming current to automatically control and prevent
catastrophic, overload conditions.

• Overvoltage Protection – during arming sequence, direct measurement of
the incoming voltage prevents damage to the internal components and ICs
from power above the rated voltage.

• Overtemperature Protection – temperatures along the MOSFET channels
and MCU are continually monitored, to prevent unsafe or damaging
operation. Output power is actively controlled to maintain optimal operating
temperatures and in-flight motor control stability.

• Stall Detection – advanced algorithms detect a blocked or stalled motor
incident during startup and in-flight operation, allowing for the immediate
shutdown of electronics in the case of a propeller impact or alternate unsafe
event.

• Data-Logging – high-memory storage, onboard EEPROM allows for
continuous logging of critical parameters (voltage, amperage, temperature,
throttle signal, throttle output, eRPM, etc.) with the ability to download and
review via standard PC-USB connection or CAN network.

• Dedicated E-RPM Output – for simple compatibility with advanced flight-
controller and flybarless-system e-governors.

• Regenerative Braking – active braking during motor deceleration phase,
providing instantaneous response to the flight controller commands and
matched-response to acceleration profiles (less “float” during flight).

• Temperature-Controlled Synchronous Rectification – new proprietary
algorithm for smooth-running motors at low-throttle and improved, faster
response under high-peak loads; all while significantly increasing flight-time
efficiency and reducing operating temperatures.

https://cdn.shopify.com/s/files/1/0496/8205/files/KDECAN_Bus_Protocol_1.0.0.pdf?11895809671989535815
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VOLTAGE CUTOFF

ON

2Enables voltage-cutoff for specific applications, resulting in a 
50% RPM limit reduction when reaching the target cell voltage 
(selectable with pull-down menu, i.e. 3.2V/CELL).

OFF
Disables voltage-cutoff, highly-recommended and default 
setting for UAS and multi-rotor flight applications to prevent 
power stall and potential loss of flight control.

ADVANCE TIMING

DYNAMIC
Dynamically adjusts advance timing (15° to 22°) to the brushless 
motor, providing higher efficiency and balance of power.

PRECISION
Dynamically adjusts advance timing (22° to 30°) for maximum 
thrust output and acceleration response (at a slight loss of 
efficiency), best for high-pole count motors and heavy-lift.

MOTOR DIRECTION

FORWARD
Default motor direction, determined by the motor windings and 
motor lead connection order.

REVERSE
Alternate motor direction (opposite of Forward setting), 
reversing the rotational direction for ease of installation.

THROTTLE CALIBRATION MODE

DYNAMIC
Factory-calibrated, automatic throttle calibration to the flight 
controller for simple, drop-in installation (ideal for most UAS and 
multi-rotor applications, such as the DJI™ A2/A3 series).

MANUAL

1Enables manual (fixed) throttle calibration.  After selection, 
throttle calibration will proceed upon next power-up:

- Turn on the transmitter and move throttle stick to maximum 
upper position (100% throttle).  Apply power to ESC.

- Motor will emit dual tones, memorizing upper position.
- Quickly move throttle stick to low position (0% throttle).
- Motor will emit tones, memorizing lower position and arming.
- Calibration is now complete and ready for operation.

RANGE

1Allows direct input of the throttle calibration, via the MIN(LOW) 
and MAX(HIGH) range.  When selected, values can be typed into 
the THROTTLE CALIBRATION RANGE textboxes:

- Allowable value for MIN(LOW): 800 to 1250 [µs].
- Allowable value for MAX(HIGH): 1750 to 2200 [µs].

PROPELLER HOLD

ENABLED

4Enables an active-brake to the propeller when minimum throttle 
position (0%) is received, providing a rapid propeller-stop and 
hold to position (ideal for emergency parachute recovery).

DISABLED
Disables an active-brake to the propeller, allowing free-spool of 
the propeller when minimum throttle position (0%) is received.

MOTOR EDITION

DEFAULT
Enables motor-drive control-algorithm optimizations for 
simple compatibility to the widest range of motors – ideal for 
the KDE4215XF and smaller series brushless motors.

KDE5215XF-220
↓ ↑

KDE10218XF-105

Enables motor-drive control algorithm optimizations for 
specific KDE Direct motor editions, ideal for the industrial 
heavy-lift brushless motor series (KDE5215XF and larger).

ACCELERATION RATE

MEDIUM
Optimizes the maximum acceleration/deceleration control 
profiles for smooth reaction-rates and safety in industrial-
heavy lift applications (dynamic reduction up to 20%).

MEDIUM-HIGH
Optimizes the maximum acceleration/deceleration control 
profiles for balanced operation in commercial aerial-
cinematography applications (dynamic reduction up to 15%).

HIGH
Optimizes the maximum acceleration/deceleration control 
profiles for increased stability in adverse weather conditions 
and long-endurance flights (dynamic reduction up to 10%).

ULTRA-HIGH
Maximizes the acceleration/deceleration control profiles for 
high-speed applications, where fast-reaction rates and tight-
control to the flight-controller commands is required.

ARMING TONES

STANDARD
Initialization of the ESC will emit voltage count tones (number of 
LiPo battery cells), followed by final arming tones.
- Safety warning tones will emit until arming signal is received.

ARM ONLY
Initialization of the ESC will emit final arming tones only.
- Safety warning tones will emit until arming signal is received.

INITIALIZE
3Initialization of the ESC will emit final arming tones only.
- Safety warning tones will not emit before arming signal.
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STALL PROTECTION

ENABLED
Enables advanced algorithms allowing for the immediate
shutdown of electronics in the case of a propeller impact or
alternate unsafe event.

DISABLED
ESC will not detect a blocked or stalled motor incident during 
startup and in-flight operation

DATA-LOG SPEED

8Hz Data is logged to EEPROM at 8Hz

4Hz Data is logged to EEPROM at 4Hz

2Hz Data is logged to EEPROM at 2Hz

1Hz Data is logged to EEPROM at 1Hz

DISABLED Data logging is disabled

OVERLOAD PROTECTION

ULTRA-HIGH
ESC will enable overload protection when witnessing a three (3) 
second continuous-current duration above 175% of the 
continuous amperage rating (i.e., 220A for the 125A ESC).

STANDARD
ESC will enable overload protection when witnessing a three (3) 
second continuous-current duration above 150% of the 
continuous amperage rating (i.e., 190A for the 125A ESC).

DISABLED
Overload protection is disabled.  Use with caution - overload 
protection is designed to protect the internal electronics from 
high continuous-current situations and circuit damage.

ESC ID (KDECAN)

INITIALIZE
ESCs with an initialized ID (unassigned ID) have an ID of 0x01. The 
CAN bus ESC ID can be assigned manually or through a KDECAN
ESC enumeration message.

FIXED CAN bus ESC ID can be set to a fixed number between 2-64

1Default calibration for Manual and Range mode is 1100µs to 1940µs and changes will be
stored to the EEPROM memory. When changing the Throttle Calibration Mode, EEPROM
memory will automatically reset to this default range for safety before calibration.
2Voltage-cutoff should always be “OFF” for UAS and multi-rotor flight applications, or a
potential loss of flight stability and control can occur during low-voltage events. Voltage-
cutoff is advantageous for single-rotor and fixed-wing applications as desired.
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KDE UVC series ESC’s have data logging capabilities built in. To enable these
features, update your ESC to firmware D460114.dfu or later and install the
KDE Device Manager V1.32 or later.

After updating the ESC to the latest firmware, during flight, the ESC will begin
to log the following attributes:

- Drive Voltage - Output Throttle
- Drive Current - RPM
- Temperature - Power Consumption
- Drive Power - Flight Number
- Input Throttle - Log Frequency
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DATA SESSIONS

Choose which session you wish to display by clicking "View" -> "Select Data
Log Session".

A new logging session is started each time the ESC is powered down or the input
throttle drops to 0. When there are multiple sessions, the Flight Number will be
displayed in the bottom right hand corner based on the current location of your
mouse cursor.

GRAPH NAVIGATION

Zoom: Left click on the chart and drag the mouse to the bottom-right
A rectangle will appear allowing you to zoom into the area selected.

Pan: The pan is controlled with the right mouse button. To pan the graph,
right-click on the chart and move the mouse in the desired direction.

Reset Zoom & Pan: Left click on the chart, similar to zoom, and drag the mouse
to the top left. Zoom and pan will reset.

DISPLAY

Click "View" -> "Display Options" to change the visibility of data plots, graph 

colors, and axis locations.

READING THE DATA LOG

1. Update the ESC to the latest production firmware

2. Install the newest KDE Device Manager from the website:
www.kdedirect.com/products/kde-dms

3. Run a test flight/motor test.

4. Connect the ESC to your computer with the USB cable provided with the
ESC.

5. Open the graph window from the menu "File" -> "ESC Data Log"

6. Press the READ ESC LOG button located at the bottom of the graph window.
The KDE Device Manager will now copy the data log from the ESC and show
the data in the graph interface. 7After the data log has been loaded from the
ESC, all graph operations are available.

GRAPHING OPERATIONS

NOTE: The Graph interface can be accessed by selecting "File" -> "ESC Data
Log" from the main window.

CHANGING UNITS

Changing the units on the graph can be done by clicking "Edit" -> "Change
Units“

If an axis is not selected in "View" -> "Display Options" the unit selection will
not be available.

The following units can be selected:
• Temperature: Fahrenheit or Celsius
• Time: Seconds or Minutes
• Power: Watts or Horsepower
• Capacity: Amp Hours or Milliamp Hours or Watt Hours

MOTOR RPM

In order to calculate motor rpm the magnetic poles of your motor must be
entered. To enter the magnetic poles select "Edit" -> "RPM Setup".

The number of magnetic poles for your motor can be found under the
specifications tab for the motor.

If the number of magnetic poles are not entered, the rpm shown will be the
electrical rpm and not the motor rpm.

SAVING / LOADING A DATA LOG

Once the data log is loaded from the ESC, you can choose to save the data log
from "File" -> "Save Data". Notes can be added when saving. You can also load
a previously saved data log from "File" -> “Load Data". Notes will appear when
the file is loaded.

PRINTING

Printing the graph can be done through "File" -> "Print".

CLEARING THE DATA LOG

To clear the data log on the ESC press the "CLEAR ESC LOG" button.

26 logs can be recorded on the ESC before it needs to be cleared. 

The progress bar, located at the bottom of the graph, will show how full the data 
logs is. When the data log runs out of space, it continues logging from the top (it 
begins overwriting the oldest logged data)

EXPORTING AS AN IMAGE

The graph can be exported as an image through "File" -> "Export Image".

http://www.kdedirect.com/products/kdexf-dma
https://www.kdedirect.com/products/kde-dms?page=specs
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KDE Direct, LLC (KDE Direct) warrants to the original purchaser that the
Product(s) will be free from defects in materials and workmanship for a period
of one (1) year from the date of purchase. This warranty does not cover abuse,
neglect, or damage to the Product(s) from preventable failure methods, such as
incorrect wiring, reverse polarity, voltage exceeding the maximum specification,
incompatible system components, or amperages exceeding the maximum
specification (overloading).

The full definition and terms of this limited warranty are available at:
https://www.kdedirect.com/pages/warranty-and-returns-policy.

All of KDE Direct’s sales are subject to its Liability Policy, available at:
http://www.kdedirect.com/pages/liability-policy. To the extent permitted by
law, KDE Direct makes no other warranty or representation, and HEREBY
DISCLAIMS ANY AND ALL IMPLIED WARRANTIES, INCLUDING, WITHOUT
LIMITATION, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT,
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. The
purchaser acknowledges that they alone have determined that the Product(s)
will suitably meet the requirements of the purchaser’s intended use.

KDE DIRECT SHALL NOT BE LIABLE FOR SPECIAL, INDIRECT, INCIDENTAL,
OR CONSEQUENTIAL DAMAGES, LOSS OF PROFITS OR PRODUCTION OR
COMMERCIAL LOSS IN ANY WAY, REGARDLESS OF WHETHER SUCH CLAIM
IS BASED IN CONTRACT, WARRANTY, TORT, NEGLIGENCE, STRICT
LIABILITY, OR ANY OTHER THEORY OF LIABILITY, EVEN IF KDE DIRECT
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. FURTHER, IN
NO EVENT SHALL THE LIABILITY OF KDE DIRECT EXCEED THE INDIVIDUAL
PRICE OF THE PRODUCT(S) ON WHICH LIABILITY IS ASSERTED. As KDE
Direct has no control over use, setup, final assembly, modification, or misuse, no
liability shall be assumed nor accepted for any resulting damage or injury. By
the act of use, setup, or assembly, the user accepts all resulting liability. If
the purchaser or users are not prepared to accept the liability associated with
the use of the Product(s), purchaser or users are advised to return the
Product(s) immediately in new and unused condition to the authorized dealer
or KDE Direct.

Always observe all laws and instructions regarding the use of this product, and
the operation of devices using this product.

KDE Direct reserves the right to change or modify its Warranty and Return
Policy and its Liability Policy at any time without prior notice.

https://www.kdedirect.com/pages/warranty-and-returns-policy
http://www.kdedirect.com/pages/liability-policy
https://www.kdedirect.com/pages/warranty-and-returns-policy
http://www.kdedirect.com/pages/liability-policy

