
IMPORTANT: To reduce the risk of fire, bodily injury, and damage to the
product, read through Instruction Manual before operating the Device
Manager and always follow all instructions.

KEEP OUT OF THE REACH OF CHILDREN.

Disconnect brushless motor from ESC (electronic speed controller) motor
leads before programming ESC. An electric motor that is connected to the
ESC can start unexpectedly and cause serious injuries or damage.

If the ESC does not include the dedicated Programming Lead (see diagrams
under Device Installation and Wiring), a 9V to 12V power source (2S to 3S
LiPo preferred) is required for powering the ESC during programming. A
maximum power source of 25V (6S LiPo) can be used for the update
procedure. Do not exceed this maximum voltage or immediate damage to the
electronics can occur.

If power is required, ensure the polarity is correct with the power
supply to the ESC power source leads. Reverse polarity may cause
fire and/or serious injury, and will immediately damage the ESC and
Device Adapter beyond warranty coverage.

KDE Direct is not responsible for the use of this Product(s) or for any
damages or injuries caused or sustained by its usage. Always observe all laws
and instructions regarding the use of this Product(s), and the operation of
devices using this Product(s).

Do not disassemble or open the Device Manager Adapter. Opening of the case
or removal of shrink-wrap may cause damage to the internal components,
void all warranty claims, and yield unsafe operation.

Ensure all connectors are protected from conductive areas to prevent
unwanted shorts and damage.

This product may contain chemicals known in the State of California to cause
cancer and/or birth defects or other reproductive harm. Do not ingest or
attempt to ingest this product.

For the latest instruction manual revisions, software updates, liability
policy, and warranty information, visit the KDE Direct website at:
http://www.KDEDirect.com.

All technical inquiries, contact support@kdedirect.com.

Pay close attention to proper wiring as shown in the diagram(s). ESC is
automatically powered via the USB Device Manager Adapter when using the
Programming Lead (orange-red-brown cable). External power is NOT required
to properly arm and program the microprocessor in most cases.

The KDE Direct Device Manager provides the ability to update and
program the KDE Direct UAS Brushless ESC Series to the latest
production firmware releases, and customize advanced options for
multiple applications. Advanced technologies, such as Synchronous
Rectification and Regenerative Braking, can be enabled for enhanced
performance and optimized control algorithms.

DEVICE INSTALLATION AND WIRING

TO DEVICE MANAGER ADAPTER
(O-R-BRN PROGRAMMING LEAD)

TO FLIGHT CONTROLLER
(W-R-BLK CONTROL LEAD)

(+) TO POWER SOURCE 
(RED POWER LEAD)

(-) TO POWER SOURCE
(BLACK POWER LEAD)

TO DEVICE MANAGER ADAPTER
(W-R-BLK CONTROL LEAD)

If the ESC does not include the dedicated Programming Lead or does not
connect, a 9V to 12V power source (2S or 3S LiPo preferred, 25V maximum) is
required for powering the ESC during programming. Once external power is
properly applied to the ESC, the microprocessor is programmed via connection
of the Device Manager Adapter to the Control Lead (white-red-black cable).
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1. Download and install the Device Manager software from the KDE Direct
Device Manager Adapter (DMA) webpage at:

www.kdedirect.com/products/kdexf-dma

2. Complete installation of the software (and all prerequisites), and run the
KDEDevice application from the Windows start menu or desktop shortcut.

3. Connect the Device Manager Adapter to an available USB port.
- Adapter will be recognized via an activated “red” LED signal.
- Adapter will change to a “green” LED signal upon recognition by the

KDEDevice application and proper installation.

4. Connect the ESC to the Device Manager Adapter, ensuring proper orientation
of the 3-wire plug (see diagrams in Device Installation and Wiring).

- Adapter will NOT be damaged with incorrect orientation. Software will
simply not recognize device until proper installation.

- Detection of the ESC via the Device Manager software may take up to
five (5) seconds to properly boot the internal microprocessor and
download current settings.

ESC PROGRAMMING AND FIRMWARE UPDATE

1. Download the latest production firmware file (make sure to choose the
appropriate version for your ESC model) from the KDE Direct website at:

www.kdedirect.com/products/kdexf-dma

2. Update the ESC to the latest production firmware release by pressing the
“UPDATE FIRMWARE” button in the Device Manager software and selecting
the downloaded firmware file (.kde).

Do not disrupt power or connection to the ESC or Adapter during the
update process, or corruption of the firmware and permanent-failure
of the ESC can occur (6ESC can be restored in most cases via the
“REPAIR MODE” feature).

3. When update is completed, the default settings will be automatically applied
to the ESC and confirmed (allow up to five (5) seconds for this to complete).

- Optimized settings will be applied to the ESC, and no additional changes
are required for correct operation with the KDE Direct UAS Multi-Rotor
Brushless Motor Series for UAS and multi-rotor applications.

- Default Settings can be reloaded by pressing the “DEFAULT SETTINGS”
button, followed by pressing the “SEND SETTINGS” button in the Device
Manager software (allow five (5) seconds to pass before unplugging).

4. Disconnect power from the ESC (if required), then disconnect the Adapter
from the ESC Programming Lead or Control Lead to complete the update.

NOTE: The KDE Direct Device Manager allows for modification of control
algorithms and tuned ESC operation – in rare instances will the Advanced
Settings need to be changed for proper UAS and multi-rotor flight application.

STARTUP POWER

DYNAMIC
Dynamically adjusts to the startup-requirements of the motor, 
optimal for most setups and KDE Direct brushless motors.

HIGH (HARD)
Increases the startup-power for high-cogging torque motors or 
high-stall loading setups.

DRIVE FREQUENCY

PRECISION
(30 kHz – 32 kHz)

Fastest PWM drive frequency to the motor, providing the 
smoothest/quietest operation (increases ESC temperature).

DYNAMIC
(16 kHz – 18 kHz)

Dynamically adjusts the PWM drive frequency to the motor, 
providing the best overall balance of performance.

BALANCED
(8 kHz – 10 kHz)

Lowers the PWM drive frequency to the motor, reducing ESC 
temperatures (increases motor commutation noise).

SYNCHRONOUS RECTIFICATION (ACTIVE-FREEWHEELING)

ENABLED
Enables synchronous rectification (also termed active-
freewheeling) for improved efficiency and regenerative braking 
algorithms ideal for UAS and multi-rotor operation.

DISABLED
Disables synchronous rectification for improved light-loading 
operation (such as motor bench-testing) and minimal-brake 
activation ideal for specific single-rotor applications.

S.R. BRAKING ACTIVATION (REGENERATIVE-BRAKING)

PRECISION
Enables synchronous rectification immediately, ideal for FPV 
racing and light multi-rotor applications.  Provides immediate 
response at spool-up and flight take-off.

DYNAMIC
Enables synchronous rectification upon reaching optimal ESC 
temperatures, allowing for smooth operation during initial 
motor spool-up and flight take-off.

BALANCED
Enables synchronous rectification upon reaching higher ESC 
temperatures, allowing for smooth operation during initial 
motor spool-up and further into initial flight.

DEVICE MANAGER SOFTWARE INSTALLATION

REVISION PR10

http://www.kdedirect.com/products/kdexf-dma
http://www.kdedirect.com/products/kdexf-dma
https://www.kdedirect.com/collections/uas-multi-rotor-brushless-motors


VOLTAGE CUTOFF

ON

2Enables voltage-cutoff for specific applications, resulting in a 
50% RPM limit reduction when reaching the target cell voltage 
(selectable with pull-down menu, i.e. 3.2V/CELL).

OFF
Disables voltage-cutoff, highly-recommended and default 
setting for UAS and multi-rotor flight applications to prevent 
power stall and potential loss of flight control.

ADVANCE TIMING

DYNAMIC
Dynamically adjusts advance timing (15° to 22°) to the brushless 
motor, providing higher efficiency and balance of power.

PRECISION
Dynamically adjusts advance timing (22° to 30°) for maximum 
thrust output and acceleration response (at a slight loss of 
efficiency), best for high-pole count motors and heavy-lift.

MOTOR DIRECTION

FORWARD
Default motor direction, determined by the motor windings and 
motor lead connection order.

REVERSE
Alternate motor direction (opposite of Forward setting), 
reversing the rotational direction for ease of installation.

THROTTLE CALIBRATION MODE

DYNAMIC
Factory-calibrated, automatic throttle calibration to the flight 
controller for simple, drop-in installation (ideal for most UAS and 
multi-rotor applications, such as the DJI™ A2/A3 series).

MANUAL

1Enables manual (fixed) throttle calibration.  After selection, 
throttle calibration will proceed upon next power-up:

- Turn on the transmitter and move throttle stick to maximum 
upper position (100% throttle).  Apply power to ESC.

- Motor will emit dual tones, memorizing upper position.
- Quickly move throttle stick to low position (0% throttle).
- Motor will emit tones, memorizing lower position and arming.
- Calibration is now complete and ready for operation.

RANGE

1Allows direct input of the throttle calibration, via the MIN(LOW) 
and MAX(HIGH) range.  When selected, values can be typed into 
the THROTTLE CALIBRATION RANGE textboxes:

- Allowable value for MIN(LOW): 800 to 1250 [µs].
- Allowable value for MAX(HIGH): 1750 to 2200 [µs].

ARMING TONES

STANDARD
Initialization of the ESC will emit voltage count tones (number of 
LiPo battery cells), followed by final arming tones.
- Safety warning tones will emit until arming signal is received.

ARM ONLY
Initialization of the ESC will emit final arming tones only.
- Safety warning tones will emit until arming signal is received.

INITIALIZE
3Initialization of the ESC will emit final arming tones only.
- Safety warning tones will not emit before arming signal.
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PROPELLER HOLD

ENABLED

4Enables an active-brake to the propeller when minimum throttle 
position (0%) is received, providing a rapid propeller-stop and 
hold to position (ideal for emergency parachute recovery).

DISABLED
Disables an active-brake to the propeller, allowing free-spool of 
the propeller when minimum throttle position (0%) is received.

MOTOR EDITION

DEFAULT
Enables motor-drive control-algorithm optimizations for 
simple compatibility to the widest range of motors – ideal for 
the KDE5215XF and smaller series brushless motors.

KDE6213XF-185
↓ ↑

KDE8218XF-120

Enables motor-drive control algorithm optimizations for 
specific KDE Direct motor editions, ideal for the industrial 
heavy-lift brushless motor series (KDE6213XF and larger).

ACCELERATION RATE

MEDIUM
Optimizes the maximum acceleration/deceleration control 
profiles for smooth reaction-rates and safety in industrial-
heavy lift applications (dynamic reduction up to 20%).

MEDIUM-HIGH
Optimizes the maximum acceleration/deceleration control 
profiles for balanced operation in commercial aerial-
cinematography applications (dynamic reduction up to 15%).

HIGH
Optimizes the maximum acceleration/deceleration control 
profiles for increased stability in adverse weather conditions 
and long-endurance flights (dynamic reduction up to 10%).

ULTRA-HIGH
Maximizes the acceleration/deceleration control profiles for 
high-speed applications, where fast-reaction rates and tight-
control to the flight-controller commands is required.
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OVERLOAD PROTECTION

ULTRA-HIGH
ESC will enable overload protection when witnessing a three (3) 
second continuous-current duration above 175% of the 
continuous amperage rating (i.e., 170A for the 95A ESC).

STANDARD
ESC will enable overload protection when witnessing a three (3) 
second continuous-current duration above 150% of the 
continuous amperage rating (i.e., 145A for the 95A ESC).

DISABLED
Overload protection is disabled.  Use with caution - overload 
protection is designed to protect the internal electronics from 
high continuous-current situations and circuit damage.

KDE UVC series ESC’s have data logging capabilities built in. To enable these
features, you will need to update your ESC to firmware D460114.dfu or later.
You will also need to install the new KDE Device Manager V1.32 or later.

After updating the ESC to the latest firmware, during flight: the ESC will begin
to log the following attributes:

- Drive Voltage - Output Throttle
- Drive Current - RPM
- Temperature - Power Consumption
- Drive Power - Flight Number
- Input Throttle - Log Frequency

DEVICE MANAGER GRAPHING

READING THE DATA LOG

1. Update the ESC to the latest production firmware (D460114.dfu)

2. Install the new KDE Device Manager V1.32 from the KDE Direct website:
www.kdedirect.com/products/kde-dms

3. Run a test flight/motor test.

4. Connect the ESC to your computer with the USB cable provided with the
ESC.

5. Open the graph window from the menu "File" -> "Export ESC Data Log"

6. Press the READ ESC LOG button located at the bottom of the graph window.
The KDE Device Manager will now copy the data log from the ESC and show
the data in the graph interface. The progress bar at the bottom of the graph
will show how full the data logs is.

BASIC GRAPHING OPPERATIONS
Graph Navigation:

Zoom: Left click on the chart and drag the mouse to the bottom-right
A rectangle will appear allowing you to zoom into the area selected.

Pan: The pan is controlled with the right mouse button. To pan the graph,
right-click on the chart and move the mouse in the desired direction.

Reset Zoom & Pan: Left click on the chart, similar to zoom, and drag the
mouse to the top left. Zoom and pan will reset.

Display:

Click "View" -> "Display Options" to change the visibility of data plots, graph
colors, and axis locations.

Data Sessions:

Choose which session you wish to display by clicking "View" -> "Select Data
Log Session".

A new logging session is started each time the ESC is powered down or the input
throttle drops to 0. When there are multiple sessions, the Flight Number will be
displayed in the bottom right hand corner based on the current location of your
mouse cursor.

Changing Units:

Changing the units on the graph can be done by clicking "Edit" -> "Change
Units“

If an axis is not selected in "View" -> "Display Options" the unit selection will
not be available.

The following units can be changed:
- Temperature: Fahrenheit or Celsius
- Time: Seconds or Minutes
- Power: Watts or Horsepower
- Capacity: Amp Hours or Milliamp Hours or Watt Hours

Saving A Screenshot:

Screenshots can be saved by clicking "File" -> "Export Image".

Motor RPM:

In order to calculate motor rpm the magnetic poles of your motor must be
entered. To enter magnetic poles select "Edit" -> "RPM Setup".
Note: If the magnetic poles are not entered the rpm shown will be the electrical
rpm and not the motor rpm.
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All of KDE Direct’s sales are subject to its Liability Policy, available at:
http://www.kdedirect.com/pages/liability-policy. To the extent permitted by
law, KDE Direct makes no other warranty or representation, and HEREBY
DISCLAIMS ANY AND ALL IMPLIED WARRANTIES, INCLUDING, WITHOUT
LIMITATION, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT,
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. The
purchaser acknowledges that they alone have determined that the Product(s)
will suitably meet the requirements of the purchaser’s intended use.

KDE DIRECT SHALL NOT BE LIABLE FOR SPECIAL, INDIRECT, INCIDENTAL,
OR CONSEQUENTIAL DAMAGES, LOSS OF PROFITS OR PRODUCTION OR
COMMERCIAL LOSS IN ANY WAY, REGARDLESS OF WHETHER SUCH CLAIM
IS BASED IN CONTRACT, WARRANTY, TORT, NEGLIGENCE, STRICT
LIABILITY, OR ANY OTHER THEORY OF LIABILITY, EVEN IF KDE DIRECT
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. FURTHER, IN
NO EVENT SHALL THE LIABILITY OF KDE DIRECT EXCEED THE INDIVIDUAL
PRICE OF THE PRODUCT(S) ON WHICH LIABILITY IS ASSERTED. As KDE
Direct has no control over use, setup, final assembly, modification, or misuse, no
liability shall be assumed nor accepted for any resulting damage or injury. By
the act of use, setup, or assembly, the user accepts all resulting liability. If
the purchaser or users are not prepared to accept the liability associated with
the use of the Product(s), purchaser or users are advised to return the
Product(s) immediately in new and unused condition to the authorized dealer
or KDE Direct.

Always observe all laws and instructions regarding the use of this product, and
the operation of devices using this product.

KDE Direct reserves the right to change or modify its Warranty and Return
Policy and its Liability Policy at any time without prior notice.
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KDE Direct, LLC (KDE Direct) warrants to the original purchaser that the
Product(s) will be free from defects in materials and workmanship for a period
of one (1) year from the date of purchase. This warranty does not cover abuse,
neglect, or damage to the Product(s) from preventable failure methods, such as
incorrect wiring, reverse polarity, voltage exceeding the maximum specification,
or amperages exceeding the maximum specification (overloading).

The full definition and terms of this limited warranty are available at:
https://www.kdedirect.com/pages/warranty-and-returns-policy.

Loading From a File:
Once the data log is loaded from the ESC, you can choose to save the data log
from "File" -> "Save Data". Notes can be added when saving. You can also load
a previously saved data log from "File" -> “Load Data".

Clearing Data From the ESC:
To clear the data log on the ESC press the "CLEAR ESC LOG" button.

Note: After data has been loaded from the ESC, unplug the ESC to increase the 
speed of the graph. 26 logs can be recorded on the ESC before it needs to be 
cleared. When the data log runs out of space, it continues logging from the top 
(it begins overwriting the oldest logged data)
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