
Congratulations on the purchase of your new Nolting NV!

NEW! The highest performance and most features are packed into this great new system. 
Touch screen control with programmable stitch regulation and adjustable brightness LED 
work light. Customizable user settings for your personal needs. Artists and pros alike will 
appreciate the sleek clean design of our new NV.

The NEW NV is the fifth generation [Roman Numeral V] of stitch regulation for Nolting 
longarms. The NV stitch regulator features the touch screen controls of four stitching 
modes plus single stitch, tie off stitches and needle up/down. The accuracy and 
responsiveness of the totally updated electronics establishes this package as the industry's 
best. Please take the time to learn all the tools the NV offers and to enjoy using them when 
you are quilting with your great new Nolting longarm.

With your new Nolting NV, you will quickly become the eNVy of your quilting friends!

The originator of longarm quilting 
machines since the 1970's

If you are ever near our factory in Eastern Iowa, the Nolting family 
would love for you to come by, see our machines and frames being 

built, or just say "hi"!

NOLTING
LONGARM QUILTING MACHINES
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Tablet User Interface

Icon Names
From left to right, the touchable icons in 
the navigation area are:

The Tablet UI is divided into two main parts: (1) Navigation and (2) Display.

Navigation 

»»  Home
»»  Lighting
»»  File Menu
»»  Sewing 

Parameters

»» Counters
»»  Profile 

Settings
»»  Measure 
»» Robotics

1

2

Active Navigation Menu
The active menu is indicated by a green 
box highlighting the navigation icon. In 
the screenshot above, Home is the active 
menu.

Non-menu Navigation 
Icons
The number on the far right of 
the navigation is not a menu. 

It displays the currently active 
quilter profile.
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Parts of a Menu
The display of each menu consists of areas, buttons, and fields. 

Display 

Area

Field
Button

Area
An area is defined by a light tan box with rounded corners.  

Button
A button is anything that can be pressed to perform an action. 

Field
A field is where numeric data is displayed.
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The Home menu consists of the (1) counter field and five areas: (2) stitch spacing, (3) 
speed, (4) needle position, (5) stitching mode, and the (6) handlebar buttons.

Counter 

Home

1
2 3

4

5

6

What It Does

The Counter displays your current 
total runtime. (See page 24 for more 
about the Counters menu.)

Counter Menu
Tapping on the Counter field will take you 
to the Counters menu.

Counter
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Stitches Per Inch (Stitch Spacing) 
What It Does
The Stitches Per Inch field shows you how 
many stitches per inch your machine is 
quilting. 
To increase or decrease the stitch spacing, 
press the plus or minus button.

Quilter Profile Stitch Spacing
Any changes made to the Stitches Per Inch 
setting will also change the stitches per inch 
of the active quilter profile’s stitches per 
inch settings.

Units of Measurement
If the NVis set to metric units, the stitch 
spacing is shown as millimeters per 
stitch.

Speed 
What It Does
Speed adjusts the speed at which your 
machine stitches. It measures this as a 
percentage of the maximum speed, which 
is about 3,000 stitches per minute.

Stitching Mode Speed
Only the Manual Stitching and Idle 
Stitching modes allow you to adjust 
stitching speed.

Needle Position 
What It Does
Needle Position determines which position 
your needle will rest in once the machine 
arm has stopped. 

Stitch Spacing

Speed
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The needle position is a general setting that 
applies to all stitching modes.
Use the up and down buttons to set your 
needle position setting.

Stitching Mode 
What It Does
Your NV has four (4) different 
stitching modes available for use: 
»» Precision Stitching
»» Manual Stitching
»» Idle Stitching
»» Baste Stitching

The green button indicates the active 
stitching mode. To switch to a new 
stitching mode, tap the appropriate 
button.

Stitching Mode Settings 
There are two possible settings for each 
stitching mode: speed and stitch spacing 
(SPI).
You can adjust the stitching mode 
settings either by using the Stitches Per 
Inch and Speed  on the Home menu or 
by accessing Settings in the Profile 
Settings menu.

Stitching Mode Setting 
Restrictions
Adjusting stitching mode settings varies 
by stitching mode. The table at right 
indicates which settings can be adjusted 
for each stitching mode.

Counter

Stitching Modes

 

Stitching 
Mode

Adjust 
Speed

Adjust 
SPI

Precision 
Stitching

 
Manual  
Stitching


Idle         
Stitching


Baste      
Stitching




Stitching Mode Settings

*
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Precision Stitching
While in the Precision Stitching mode, 
the speed of the needle is regulated by 
how quickly or slowly you move the 
handlebars. To give you consistent, even 
stitches, the needle only stitches after 
you press the start button and move the 
handle bars.
Speed Settings
Because Precision Mode regulates the 
stitching speed to ensure consistent 
stitch spacing, you may not adjust the 
stitching speed. 
Stitch Spacing (SPI) Settings
The stitch spacing can be set from 4 to 22 
stitches per inch.

Manual Stitching
While in Manual Stitching mode, the 
motor stitches the needle at a constant 
speed regardless of whether you move 
the handle bars or not.
Speed Settings
Because Manual Stitching is constantly 
stitching, you may set the speed of 
Manual Stitching mode.
Stitch Spacing (SPI) Settings
Because Manual Stitching is constantly 
stitching, you may not set the stitch 
spacing of Manual Stitching mode.

Idle Stitching
Idle Stitching is a hybrid of both 
Precision Stitching and Manual 
Stitching. 
While in Idle Stitching mode, the speed 
of the motor driving the needle adjusts 
to how quickly or slowly you move the 

Precision Mode

Idle Mode

Manual Mode
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handlebars. When you are not moving 
the handle bars, the machine will idle 
and eventually time out.
Speed Settings*
In Idle Stitching Mode, the speed set 
controls the speed at which the needle 
idles. This speed can be set from 5% to 
40%.
*The speed setting for Idle Mode has no
effect on the regulated stitching speed.
Stitch Spacing (SPI) Settings
Because the stitch spacing is regulated, 
you can set the Stitches Per Inch. 
Remember that when you aren’t moving 
the handle bars, the needle will still stich 
at an idle speed.

Baste Stitching
Baste Stitching is used to baste your quilt 
layers together.
Speed Settings
You may not adjust the stitching speed in 
Baste Stitching Mode.
Stitch Spacing (SPI) Settings
You can adjust the stitch spacing as 
normal.

Baste Mode

Revised May 2016



	 Page 11

Handle Bar Buttons 
What It Does
Each handle bar of your NV contains 
two programmable buttons. These 
four buttons can be programmed to 
perform functions. For more on 
programming handle bar functions, 
see Profile Settings on page 27.

Touchscreen Handle Bar Buttons
In addition to pressing the buttons 
on the handle bars, the programmed 
function for each button can be engaged 
by pressing the respective color key on 
the Home menu display. 
The blue and white buttons of the left 
handle bar are located in the lower-left 
corner of the Home menu display, while 
the red and green buttons of the right 
handle bar are located in the lower right 
of the Home menu display.

Left Handle Bar

Right Handle Bar
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The Lighting  menu controls the LED lights located under your handle bar cover. 
Perfect Stitch includes both a white light, a black light and the laser light.

Brightness Slider 

Lighting

What It Does
The Brightness Slider adjusts the 
brightness of the white LED lights.

Adjust Brightness
To adjust the brightness of the white LED 
lights, press the plus and minus buttons. 
Pressing and dragging on the slider knob or 
tapping on the slider track will also adjust 
the brightness of the white LED lights.
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White Light/Black Light 
What It Does
To activate or deactivate a light, press the 
white or black light button. 

Active Light
If the light button is green, then that light is 
activated. Also, the Lighting icon in the 
navigation menu changes to indicate which 
light is active.

Laser Light 
What It Does
To activate the laser light, press  the laser 
light button.  To dim the laser, there is a 
dial on the left side of the back of the 
machine.  Turning it to the right brightens 
the laser, while turning it to the left dims 
the laser.

dimmer switch
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The File menu contains Calculator, Save Settings, Advanced, and Diagnostics.

File Menu

Calculator 
What It Does
Calculator can help you perform basic 
calculations. Any numbers in the number 
field will remain even after the calculator 
is closed.

Calculator Memory
The calculator is able to store a number 
in the calculator memory for later use. 
Below is an explanation of the memory 
keys.
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MC – Memory Clear. Clears out any 
number in the memory to be zero.
MR – Memory Recall. Recalls the number 
in memory as if you had keyed the number 
in.
MS – Memory Store. Stores the number in 
the number field in the calculator memory.
M+ – Memory Add. Adds the current 
number in the number field to the number 
in memory. Then, this sum becomes the 
new number in memory. 

Save Settings 
What It Does
Profile and machine settings are 
automatically saved every five minutes.
Save Settings 
Saves all of the NV settings that are part 
of the quilter profile as well as global 
settings, such as the counter totals and 
the currently open menu. This is helpful 
if you have made changes to the settings 
but need to turn off your machine right 
away.

Save Your Settings
Press the Save Settings button.
After pressing Save Settings, a window 
will appear confirming that your current 
settings have been saved.

Save Settings
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Advanced 
What It Does
The Advanced button leads you to a 
second level menu. The options in this 
menu are system related, and won’t be 
accessed often. 

Timeout
Timeout  allows you to customize 
how many seconds NV will remain 
active without user input before 
becoming inactive. 
NV will not timeout if the encoders 
sense any movement. If NV is not 
timing out, make sure that nothing is 
causing the encoders to sense 
movement.

System Information
The System Information  button 
displays information about your NV 
software. There are three layers of 
information: the Quilt EZ screen, the 
Qt Screen, and the License Information 
screen. These screens contain information 
about which version of software, 
robotics, and quilting machine you are 
currently using, as well as some licensing 
information.

System Log
The Syst em Log  button displays a record 
of any errors that have occured. When 
troubleshooting NV, you may be asked 
to provide information from the system 
log.
The system log contains the Reset, Save, 
and Exit buttons.

Time Out

System Information

System Log
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Reset
The Reset button temporarily clears all 
of the recorded actions from your system 
log. The system log will be restored upon 
pressing the Exit button.
Save
The Save button will save the contents of 
the system log to any currently inserted, 
compatible USB stick. Once the system 
log is saved, the system log contents are 
deleted from the tablet.
Exit
The Exit button returns you to the 
previous menu.

Update System
Update System is used to update your 
Perfect Stitch, which can include the 
stitching, tablet, and robotics systems. 
Pressing the Update System button while 
an update-loaded USB is inserted will 
lead you to an update menu.

Update Machine
Update Machine is used to only update 
the firmware of the stitching system. 
Pressing the Update Machine button 
while an update-loaded USB stick is 
inserted will lead you to an update menu. 

Update System

Update Machine
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Robot Demo Interface
Robot Demo Interface allows access to 
the robotics user interface. The features 
of the robotics interface can be explored 
without causing your machine to react by 
stitching.
The demo is used mostly by dealers as a 
way to explain the features of the robotics, 
and should never need to be engaged.

Metric Units
If NV is set to metric units, the relation 
of stitches to units of measurement is 
inversed. In other words, it shows you 
the number of millimeters per stitch, not 
the number of stitches per millimeter. 
Also, measurments will be displayed in 
metric units. 
To enable metric units, tap on Metric 
Units.

Disable Robot Port
Disable Robot Port allows you to disable 
any robotics connected to your quilting 
machine. This is most often used to 
troubleshoot machine service issues and 
will not commonly be engaged.

Disable Rear Port
Disable Rear Port allows you to disable 
the rear port of your quilting machine. 
This is most often used to troubleshoot 
machine service issues  and will not 
commonly be engaged.

Robot Demo Interface

Metric Units

Disable Robot Port

Disable Robot Port
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What It Does
Diagnostics contains tools to determine 
if your quilting machine is operating 
optimally. These tools are the Motor 
Index, Motor Encoder, Motor Settings, 
Temperature, Top Encoder, Bottom 
Encoder, Handle Bar Buttons, Needle 
Up/Down, and the Jog Dial.

Motor Index
The Motor Index measures the number 
of needle ups and tracks whether the 
needle is up or down.  
When the Motor Index button is pressed, 
it displays the total number of needle ups 
recorded on the index sensor board since 
the machine was last turned on.

Motor Encoder
The Motor Encoder measures your 
machine speed. It is used to test that the 
motor is operating at normal levels. The 
measurements in the Motor Encoder 
reset to zero every time you display them 
by pressing the Motor Encoder button.

Motor Settings
Motor Settings allows you to adjust 
performance settings of the motor. If 
improperly changed, these settings 
can damage your machine. Because 
of this, these settings are password 
protected. ONLY ADJUST THE MOTOR 
SETTINGS UNDER THE DIRECTION 
OF TRAINED SUPPORT PERSONNEL.

Diagnostics 

Motor Index

Motor Encoder

Motor Settings
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Temperature
The Temperature button displays the 
current operating temperature of your 
motor. Safe levels of operation are under 
100 degrees Celsius. If your motor 
exceeds safe levels, an error message will 
display on the tablet screen.
If your machine temperature displays 
above 100 degrees Celsius, contact your 
local dealer for support.

Top Encoder
The Top Encoder button displays the Y 
coordinates of the stitching system. The 
number displayed should change when 
you push the handle bars away from or 
towards yourself. 

Bottom Encoder
The Bottom Encoder button displays the 
X coordinate of the stitching system. The 
number displayed should change when 
you push the handle bars to the left or to 
the right.

Handle Bar Buttons

The Handle Bar Buttons can be tested 
from Diagnostics. To test the buttons, 
you must press the buttons on the handle 
bar. The handle bar buttons on the tablet 
screen are not functional.
Pressing a handle bar button while in 
Diagnostics will engage that button’s 
programmed function. When a handle 
bar button is pressed, the corresponding 
button in Diagnostics will turn green to 
indicate that it is working properly (see 
the red button in the screenshots at right). 
Unlike any other menu, pressing a 
handle bar button while in Diagnostics 
will not return you to the Home menu

Temperature

Top Encoder

Bottom Encoder

Handle Bar Buttons
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Needle Up/Down

The Needle Up/Down area contains 
buttons to test the needle up and needle 
down function of your stitching system. 
Press the up and down buttons to raise or 
lower the position of your needle.

Jog Dial
The dial button gives you access to the 
Jog Machine area.
From time to time, your machine may 
become bogged down to the point where 
the needle is stuck and refuses to move.
If this happens, it may be necessary to 
“jog” the machine.
Jog Your Machine
To jog your machine, select one of the 
two jog settings. After a setting is selected, 
use the plus or minus buttons or touch 
and drag the dial. The two jog settings are 
Position Mode and Power Mode.

Position Mode
Position Mode will apply as much power 
as it needs to move the needle to the pre-
determined up/down positions. Negative 
values run the motor in reverse, while 
positive values run the motor as normal.

Power Mode
Power mode will send power directly to 
the motor of your stitching system. This 
mode is recommended to “jog” your 
machine. 

Needle Up/Down

Jog Dial

Position Mode

Power Mode

The following information is for when your needle or hook 
becomes stuck for any reason.  We always reccomend using the 
handwheel at the back of the machine to "unstick" the hook first.  
If you feel you need to do any of the following "jogging", please 
contact us first.
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The Sewing Parameters menu contains Stop Mode and Tie-Offs. These are used 
to set what actions your machine will take whenever it stops stitching and how many 
stitches to use for a tie-off.

Sewing Parameters

Stop Mode 
What It Does
Stop Mode contains three buttons: Ndl 
Pos, Quick, and Tie Off. Only one button 
can be active at a time.

Ndl Pos (Needle Position)
When the Ndl P os  button is selected, the 
stopped needle will return to the needle 
position of the currently active quilter 
profile. (For more on quilter profiles, 
see page 27.)

Needle Position
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Quick
When the Quick button is selected, 
whenever a needle is stopped using 
a handlebar button, it will stop 
immediately, regardless of its current 
needle position.

Tie Off
When the Tie Off button is selected, the 
stopped needle will tie off the number of 
times specified in the Tie-Offs area.

Tie Offs 
What It Does
The Tie-Offs area sets how many stitches 
your machine will stitch to tie-off the 
thread. 

Adjust Tie-Offs
Press the plus or minus buttons to add or 
remove stitches to your tie off settings.

Quick

Tie Off

Adjust Tie-Offs
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The Counters menu contains the Run Time and Stitch Counter areas.

Counters

Run Time 
What It Does
Runtime is measured between pressing 
the start button and when Perfect Stitch 
times out. Turning the machine off and 
on will not reset the total recorded run 
time. 

Reset
To reset the recorded run time to 0, press 
the Reset button.

Needle Position
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Stitch Counter 
What It Does
Stitch Counter displays the number 
of stitches the machine has completed. 
Turning the machine off and on will not 
reset the recorded number of stitches. 

Reset
To reset the recorded stitches to 0, press 
the Reset button.

Needle Position
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Profile Settings allows you to adjust your quilter profiles. Profile Settings contains 
Profiles (1-5), Stitching Mode Settings, and Handle Bar Buttons.

Profile Settings

Profiles (1-5)  
What It Does
There are five unique quilter profiles 
available in NV. Each profile can have 
unique settings from the other profiles. 
The active profile is displayed in the top 
right corner of the navigation. (Profile 1 
shown above) 
Any changes made here will be reflected 
in the corresponding stitching mode 
settings shown on the Home menu.
The active profile is indicated by the green 
button color. To select a different profile, 
tap on a numbered profile button.
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Stitching Mode Settings 
What It Does
These are the settings for the currently 
selected quilter profile. Changes made 
from the profile settings affect their 
corresponding Home menu settings, and 
vice versa. To change a setting, tap on its 
number field and use the plus and minus 
buttons above or below it.

Prec SPI:
This adjusts the stitches per inch 
setting for Precision Mode. (For more 
information about Precision Mode, 
see page 9.)

Baste SPI:
This adjusts the stitches per inch setting 
for Baste Mode. (For more information 
about Baste Mode, see page 10.)

Idle SPI:
This adjusts the stitches per inch setting 
for Idle Mode. (For more information 
about Idle Mode, see page 9.)

Idle Speed:
This adjusts the Idle speed setting for Idle 
Mode. (For more information about Idle 
Mode, see page 9.)

Manual Speed: 
This adjusts the stitching speed setting 
for Manual Mode. (For more 
information about Manual Mode, see 
page 9.)

Precision Mode

Baste Mode

Idle Mode

Idle Speed

Manual Speed
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Handle Bar Buttons  
What It Does
Handle Bar Buttons can be uniquely 
configured for each quilter profile. The 
blue and white buttons located in the L 
area program the left handle bar buttons, 
while the red and green buttons located 
in the R area program the right handle 
bar buttons.

Handle Bar Functions
To program a button, tap on it. To replace 
the current function, Select a function for 
the handle bar button. 
The table on the next page includes each 
function icon, it’s name, and a description 
of what the function does.
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Full Stitch

Half Stitch

Start

Precision

Idle

Tie Off

Baste

Manual

None

Complete one full stitch (needle up and down)

Complete one half of a stitch (needle up or 
down)

Activate current Stitching Mode

Switch to Precision Mode

Switch to Idle Mode

Tie Off the thread

Switch to Baste Mode

Switch to Manual Mode

No function assigned to button

Icon Function Description

Handle Bar Button Functions
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The Measure Menu allows you to make quilt measurements using NV. 

Measure

Set Start/Stop 
What It Does
Set Start/Stop allows you to take 
measurements between two points on 
your quilt using hardware built into 
Perfect Stitch.

Take a Measurement
To begin a measurement, position the 
needle directly over the start of where you 
would like to measure. Once the needle is 
positioned, press the set start button.
NV will now record the distance between 
wherever you move the needle and the 
start point. This distance will display on 
the screen as you move the needle.
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Stop Measuring
To stop measuring, press the Stop 
button. Note that the last measurements 
taken will remain displayed until a new 
measurement is taken. 
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The Robotics Menu is a link to the robotic quilting system user interface. Tap the 
icon to navigate to the robotic quilting system user interface.

Robotics

No Robotics Connected
If your machine is not currently 
connected to a robotic quilting system, 
Then the icon will be colored grey, 
indicating it is inactive.

Robotics 
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