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Welcome to Composer
Composer is your digital interface between STL or SLC data and your Asiga 3D 
printer.

This guide will introduce key components of the software and also assist you through the 
simple build setup process.  

Index

> Hardware Recommendations:  What you need to run Composer

> Mouse Control Functions:  Move/rotate parts and the viewing area 

> Add a New Platform:  Add a new build platform

> Add/Import STL or SLC data:  Import STL &/or SLC data

> Position/Arrange your Parts:  Manually place or Auto-arrange parts

> Part Manipulation Tools:  Translate, Rotate, Scale, Mirror, Copy, Measure

> Generate Support Structures:  Automatically generate support structures

> Submit Build:  Submit your build to your system
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Hardware Requirements
Processor Intel Pentium 4 or AMD Athlon 64
Main memory 512 MB of free memory
Storage 200 MB of free space
Graphics OpenGL 2.0 Compatible
Network Adapter Standard Ethernet/LAN
Operating system Windows XP SP3 or later

Mouse Functions
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>> Launch Composer

1.  New Platform
You will first see a welcome screen which will allow you to quickly select one of the three 
most common start-up options.

 Click ‘NEW Build’

A New Build dialog box will appear and display the list of available printers on your network, 
material options and layer thicknesses. 

Note: you cannot continue without being able to see your printer.
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Select your Target Printer
Here you will see the list of printers available on your network.  You can choose to refresh 
the list, Add a new printer by IP address and also open the web interface for your printer.  To 
enable selection of material & layer thickness, select your printer from the list.

New Build Settings 
You will be prompted to make a selection for Material and also the slice thickness you wish to 
build at.  Note: you can change these settings later in the build dialog box:  Edit>Build 
Properties

Once you are happy to proceed click ‘OK’ and your platform will appear.
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2.  Add Parts

You can load both STL and SLC parts simultaneously into the same build which 
gives you greater flexibility with the type of data you can handle.

 Click ‘Add Parts’

You will see the ‘Add Parts‘ dialog box.  Here you can chose to:

• Add Parts
• Add Recent Parts
• Clear List
• Remove Selected

You can also Drag&Drop files directly into Composer or into this dialog box
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Once you have parts selected you can choose a range of positioning functions, open linked 
support structures (should some already exist), change the unit measurement and update 
quantity.

You can save your preferred ‘Add Part’ configuration in ‘Add Defaults’
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Once you are happy with your selection click ‘Open’.  
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You are now ready to prepare your file(s) for printing.
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3.  Auto-Place

You can manually place your parts or simply use the Auto-Place function

 Click ‘Auto-Place’

Place Parts
Choose to place all parts, selected parts or just the parts that sit outside of the platform area.

X, Y Placement  
Place parts by bounding box or to maximize your build area, place parts by the part contour. 
Input part spacing and the margin around the build plate.   You can switch this off should you 
manually place a part and then wish to level In Z.
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Z Placement
Finally choose your Z height, this is the height a part will sit away from the build glass.  Asiga 
recommends a Z height of 2-3mm to ensure you can easily remove the part from the build 
glass.

Manual Part Placement

 Move Part – Left Click & Hold 
Select the part you wish to move.  Left click & hold button to move the part.  You will 
see the color of the hand change, this indicates that ‘move part’ is now activated.  
Note: You must hold the left mouse button until you are happy with placement and 
then release to drop the part.
 

 Rotate – Right Click & Hold 
Select the part you wish to rotate. Right click & hold to rotate the part.  You can rotate 
in 15° increments by holding down the ‘shift’ key

Rotate Constraints
To enforce rotation of a part around a specific axis, hold down the axis letter on the 
keyboard i.e. hold down X to rotate around X, hold down Y to rotate around Y.  By 
holding shift at the same time you will rotate in increments of 15°.

Note: You may also scale your models using the middle-button on your mouse.  You 
can scale by factors of two by holding down the shift ket at the same time.  However, 
you may prefer to use the transformation panel (described later) for more accurate 
control.

Parts ‘Snap’ to the build extents of the build platform for convenience.  You can turn this 
feature on/off in Options>Snap to Platform.
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4.  Generate Supports

Automatic & manual support placement for quick and easy build setup. 

 Click ‘Generate Supports’

Support structures can be applied automatically or manually by using the ‘Add and Remove’ 
buttons.
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Support Parts
You have options which parts to support.

All Parts
Generate supports for all parts in the current build

Selected Parts
Support parts that are selected only

Without Support
Support all parts that currently do not have support structures

Z Height Leveling (optional)
Automatically levels all parts to a set height in Z prior to supporting.  This is a security 
feature ensuring that all parts are at a set height prior to supporting.

Support Placement

Self-support angle
This is the angle at which layers will be self supporting

Side-feature size
The distance a detail can protrude form a surface without being supported

Material Strength
Controls the number of support points required.  This is dependant on the strength of 
material.  The higher the value, the fewer supports are required 

Support spacing
Distance between support points

Torsion Tolerance
Angular moment in millimetres squared.
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Support Geometry
Diagram below illustrating the geometry of a support point

Contact Width
The width of the support point as it contacts the part.  

Over-shoot
The distance the support point intersects with the model

Maximum Width
The maximum width at the base of the support structure.  

Aspect Ratio
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The rate at which the support structures widens.  The smaller the value, the slower 
they widen to the maximum width

Automatic Supports
Support structures are required for downward facing surfaces/points and for details that 
protrude a certain distance from a surface.  You can control the placement of the support 
structures and also the geometry of them by altering these settings.  Below is a diagram 
highlighting where supports are required for this particular part (shown in orthographic view).

Diagram below highlights in green a 20° angled surface that requires support structures.  
Above 20° the surface will be self supporting.
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Image showing part automatically supported in Composer.  

Note how the text is not supported as the ‘side-feature size’ was set to 1.50mm.  This means 
that any protruding detail measuring 1.50mm or less will not be supported.
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If there are any support structures that you do not wish to keep then you can remove these 
easily by using the manual support settings.
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Manual Editing Mode
You can manual add/remove support structures and also add casting sprues.

Before you start adding manual supports, ensure that you have the desired Geometry 
settings. Manually placed supports are placed on the point you click with your mouse.  

Add Supports
Select ‘Add’
Click the point on the part where you wish to place the support.  

Remove Supports
Select ‘Remove’
Click the support you wish to remove.

To add a casting sprue, simply input the diameter of the sprue and the overshoot distance 
then click the point you wish to add the sprue. 
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5.  Transform Panel

There are a number of handy tools within Composer that allow you to quickly 
make duplicates, change the scale of a parts, mirror etc.

Transform Panel
With a part selected the transform panel will become active.
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Translate
Move parts accurately along a chosen axis. 

Rotate
Rotate parts around a chosen axis

Scale
Scale parts uniformly or along a chosen axis

Mirror 
Mirror & create a copy along a chosen axis

Other Handy Tools

Locate / Replace
Tools>Locate/Replace Part 
Right click a part to 
This function allows you to reload an updated part without having to place it.

Measure
Select between two points for quick and accurate part measurement

Duplicate
Make an exact copy of a part

Measure
Select between two points for quick and accurate 

Measure
Select between two points for quick and accurate 

measurements. 
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6.  Build Wizard

All your final build parameters are set in the handy Build Wizard.

  Click ‘Build’

Choose whether you want to build all parts or selected parts.

Click ‘Next’
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What is a Base Plate?
A ‘base plate’ is an area, a number of layers thick that is printed directly onto the build plate.  
This is required when building parts with support structures as it helps bond the supports to 
the build plate.  For parts that are to be printed directly from the build plate, set the base plate 
thickness to zero.

• Input Base Plate thickness.  0.30mm is recommended.
Note: If you do not want a Base Plate then set this value to zero

• Select the type of Base Plate
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Base Plate Type
Choose Base Plate style

Full
Base Plate covers printable area.  Easy to clean a full tray of parts when they are 
joined to a single Base Plate

Shadow
Outline of part only.  Ideal for parts that are to be removed from the printer individually.

Bounding Box
Base Plate by bounding box of part.  

You can print parts with or without supports on the same build. To build an unsupported part 
directly from the glass but a supported part with a base-plate, simply choose the Shadow or 
Bounding Box base plate type and then tick the box to allocate this plate to be present on 
‘Supported Parts Only’.
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Placement
Choose whether you would like the base plate to be underneath the parts / supports or 
intersecting.

Click ‘Next’
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Advanced Parameters
Here you can adjust cure times and velocity/speed of slider and Z stage.

By changing the machine build parameters can have an affect of machine stability and build 
resolution.  Once a value has been changed, the box background color will change to yellow.

Here you can also view the Estimated Build Time as changes to these settings will affect 
build time.
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See below a description of each of these settings:

Slice Thickness
This is the chosen slice thickness (cannot be changed)

Burn-in Range
See Diagram.

The first number of layers are cured for longer/deeper at the start of the build to ensure either 
the base plate or parts bond sufficiently to the build glass.

Separation Distance
The distance the build glass moves in Z after the image has been exposed.

Separation Velocity
The speed at which the machine separates each layer from the Teflon film.

Approach Velocity
The speed the build glass moves in Z to position for the next layer

Slider Velocity
The speed of the slider

Slider Per Layer
Number of slides per layer

Burn-in Exposure Time
The length of time an image is projected onto the resin during the burn-in height
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Burn-in Wait Time (After Slide)
The amount of time the machine will wait after the slider has moved into position.  Burn-in 
range only

Burn-in Wait Time (After Exposure)
The amount of time the machine will wait after an image has been exposed onto the resin.  
Burn-in range only
Burn-in Wait Time (After Separation)
The amount of time the machine will wait after the machine has separated the cured layer 
from the Teflon film.  Burn-in range only

Burn-in Wait Time (After Approach)
The amount of time the machine will wait after the machine has moved into position for the 
next exposure.  Burn-in range only

Exposure Time (Normal)
The length of time the image is exposed onto the resin whilst printing the part. Part only

Normal Wait Time (After Slide)
The amount of time the machine will wait after the slider has moved into position. Part only

Normal Wait Time (After Exposure)
The amount of time the machine will wait after an image has been exposed onto the resin. 
Part only

Normal Wait Time (After Separation)
The amount of time the machine will wait after the machine has separated the cured layer 
from the Teflon film. Part only

Normal Wait Time (After Approach)
The amount of time the machine will wait after the machine has moved into position for the 
next exposure. Part only

Waiting time (After leveling)
The wait time before the next image is exposed after the slider has leveled the resin.
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Waiting Time (After Peeling)
The time the machine waits before lowering the part back into the resin after exposing a 
layer.

Click ‘Next’

Build Summary
Enter a build name and click ‘Send Build’

Your build will now be transferred to your printer.
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You can now find this build waiting on your printer.
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7.  Tools

Composer is packed full of handy tools and features to help you work through 
your build processing.  

Undo
Ctrl + Z

 Redo
Ctrl + Shift + Z

Delete
Delete

Rectangular Select
View > Actions Toolbar

  Clone
Ctrl + C
Edit > Clone

 Locate/Replace Part
Tools > Locate/Replace Part

Build Time
View > View Toolbar

 Measure
View > View Toolbar
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Snap to Platform
Options > Snap to Platform

Views
All view functions are toggled.  

Isometric Front/Back View Toggle

Top/Bottom View Toggle

Front/Back View Toggle

Left/Right View Toggle

View Platform in build orientation

Perspective View
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